首页 > 其他 > 详细

hdu1247Hat’s Words (组合单词,字典树+DFS)

时间:2014-07-26 15:02:10      阅读:478      评论:0      收藏:0      [点我收藏+]
Problem Description
A hat’s word is a word in the dictionary that is the concatenation of exactly two other words in the dictionary. You are to find all the hat’s words in a dictionary.

Input
Standard input consists of a number of lowercase words, one per line, in alphabetical order. There will be no more than 50,000 words. Only one case.

Output
Your output should contain all the hat’s words, one per line, in alphabetical order.

Sample Input
a ahat hat hatword hziee word

Sample Output
ahat hatword
#include<stdio.h>
#include<iostream>
#include<string.h>
#include<algorithm>
using namespace std;
typedef struct nn
{
    int flag;
    struct nn *next[26];
}node;
typedef struct strin
{
    int len,indx;
    char str[105];
}String;
int cmp(String s1,String s2)
{
    return s1.len<s2.len;
}
int cmp1(String s1,String s2)
{
    return s1.indx<s2.indx;
}
node *builde()
{
    node *p=new node;
    p->flag=0;
    for(int i=0;i<26;i++)
    p->next[i]=NULL;
    return p;
}
node *root;
void insert(char s[])
{
    node *p=root;
    for(int i=0;s[i]!='\0';i++)
    {
        if(p->next[s[i]-'a']==NULL)
        p->next[s[i]-'a']=builde();
        p=p->next[s[i]-'a'];
    }
    p->flag=1;
}
String s[50005];
int flog;
void dfs(int k,int si,int num)
{
    node *p=root;
    if(num>2)
         return ;
    if(si==s[k].len)
    {
        if(num==2)flog=1; return ;
    }

    for(int j=si;j<s[k].len;j++)
    {
        if(p->next[s[k].str[j]-'a']==NULL)
            return ;
        p=p->next[s[k].str[j]-'a'];
        if(p->flag)
        {
            dfs(k,j+1,num+1); if(flog!=0) return ;
        }
    }
}
int main()
{
    int n=0,m=0;
    while(scanf("%s",s[n].str)>0&&s[n].str[0]!='#')
    {
        s[n].len=strlen(s[n].str); s[n].indx=n; n++;
    }
    sort(s,s+n,cmp);
    root=builde();
    for(int i=0;i<n;i++)
    {
       flog=0; dfs(i,0,0);
       if(flog==1)s[m++]=s[i];
       insert(s[i].str);
    }
    sort(s,s+m,cmp1);
    for(int i=0;i<m;i++)
    printf("%s\n",s[i].str);
}


hdu1247Hat’s Words (组合单词,字典树+DFS),布布扣,bubuko.com

hdu1247Hat’s Words (组合单词,字典树+DFS)

原文:http://blog.csdn.net/u010372095/article/details/38144069

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!