首页 > 其他 > 详细

hdu 2660 Accepted Necklace(01-背包变形 || DFS)

时间:2014-07-27 11:10:02      阅读:253      评论:0      收藏:0      [点我收藏+]

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=2660


----------------------------------------------------------------------------------------------------------------------------------------------------------
欢迎光临天资小屋bubuko.com,布布扣bubuko.com,布布扣bubuko.com,布布扣bubuko.com,布布扣http://user.qzone.qq.com/593830943/main

----------------------------------------------------------------------------------------------------------------------------------------------------------

Accepted Necklace

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2557    Accepted Submission(s): 1017


Problem Description
I have N precious stones, and plan to use K of them to make a necklace for my mother, but she won‘t accept a necklace which is too heavy. Given the value and the weight of each precious stone, please help me find out the most valuable necklace my mother will accept.

Input
The first line of input is the number of cases.
For each case, the first line contains two integers N (N <= 20), the total number of stones, and K (K <= N), the exact number of stones to make a necklace.
Then N lines follow, each containing two integers: a (a<=1000), representing the value of each precious stone, and b (b<=1000), its weight.
The last line of each case contains an integer W, the maximum weight my mother will accept, W <= 1000.
 
Output
For each case, output the highest possible value of the necklace.
 
Sample Input
1 2 1 1 1 1 1 3

Sample Output
1

第一种、01-背包变形:

#include <cstdio>
#include <cstring>
int max(int x, int y)
{
	return x>y?x:y;
}
int dp[1017][21];
int main()
{
	int W,val[1017],wei[1017];
	int n, k, t, i, j, l;
	
	while(~scanf("%d",&t))
	{
		while(t--)
		{
			memset(dp,0,sizeof(dp));
			scanf("%d %d",&n,&k);
			for(i = 0 ;i < n; i++)
			{
				scanf("%d %d",&val[i],&wei[i]);
			}
			scanf("%d",&W);
			for(i = 0; i < n; i++)
			{
				for(l = W; l >= wei[i]; l--)
				{
					for(j = 1; j <= k; j++)
					{
						dp[l][j] = max(dp[l][j],dp[l-wei[i]][j-1]+val[i]);
					}
				}
			}
			printf("%d\n",dp[W][k]);
		}
	}
	return 0;
}


第二种、DFS:

待更新……

hdu 2660 Accepted Necklace(01-背包变形 || DFS)

原文:http://blog.csdn.net/u012860063/article/details/38168609

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!