首页 > 其他 > 详细

hdu 2035 人见人爱A^B

时间:2018-10-06 20:11:00      阅读:167      评论:0      收藏:0      [点我收藏+]

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 53935    Accepted Submission(s): 36004


Problem Description
求A^B的最后三位数表示的整数。
说明:A^B的含义是“A的B次方”
 

 

Input
输入数据包含多个测试实例,每个实例占一行,由两个正整数A和B组成(1<=A,B<=10000),如果A=0, B=0,则表示输入数据的结束,不做处理。
 

 

Output
对于每个测试实例,请输出A^B的最后三位表示的整数,每个输出占一行。
 

 

Sample Input
2 3 12 6 6789 10000 0 0
 

 

Sample Output
8 984 1
 

 

Author
lcy
 

 

Source
 

 

Recommend
lcy   |   We have carefully selected several similar problems for you:  1021 1008 1108 1061 1425 
 
简单快速幂。
代码:
#include <iostream>
#include <cstdio>
#include <algorithm>
#define inf 0x3f3f3f3f
#define MAX 100000
using namespace std;

int n,m;
int main() {
    while(~scanf("%d%d",&n,&m) && (n + m)) {
        int ans = 1,x = n,y = m;
        while(y) {
            if(y % 2) ans = (ans * x) % 1000;
            y /= 2;
            x = (x * x) % 1000;
        }
        printf("%d\n",ans);
    }
}

 

hdu 2035 人见人爱A^B

原文:https://www.cnblogs.com/8023spz/p/9748157.html

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!