首页 > 其他 > 详细

2017 ACM/ICPC 沈阳 K题 Rabbits

时间:2018-10-14 11:06:51      阅读:249      评论:0      收藏:0      [点我收藏+]
Here N (N ≥ 3) rabbits are playing by the river. They are playing on a number line, each occupying a different integer. In a single move, one of the outer rabbits jumps into a space between any other two. At no point may two rabbits occupy the same position. 
Help them play as long as possible

InputThe input has several test cases. The first line of input contains an integer t (1 ≤ t ≤ 500) indicating the number of test cases. 
For each case the first line contains the integer N (3 ≤ N ≤ 500) described as above. The second line contains n integers a1a1 < a2a2 < a3a3 < ... < aNaN which are the initial positions of the rabbits. For each rabbit, its initial position 
aiai satisfies 1 ≤ aiai ≤ 10000. 
OutputFor each case, output the largest number of moves the rabbits can make. 
Sample Input

5
3
3 4 6
3
2 3 5
3
3 5 9
4
1 2 3 4
4
1 2 4 5

Sample Output

1
1
3
0
1
签到题:Orz
#include<bits/stdc++.h>
using namespace std;
int T,num[510],sum[510];
int main()
{
    scanf("%d",&T);
    while(T--)
    {
        int n;
        scanf("%d",&n);
        int len=0;
        for(int i=1;i<=n;i++) scanf("%d",&num[i]);
        for(int i=1;i<n;i++) sum[i]=num[i+1]-num[i]-1,len+=sum[i];
        int ans=len-min(sum[1],sum[n-1]);
        printf("%d\n",ans);
    }
    return 0;
}

  

2017 ACM/ICPC 沈阳 K题 Rabbits

原文:https://www.cnblogs.com/songorz/p/9784969.html

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!