首页 > 其他 > 详细

hdu 1532 poj 1273 Drainage Ditches (最大流)

时间:2014-07-29 14:34:22      阅读:319      评论:0      收藏:0      [点我收藏+]

Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 55276   Accepted: 21122

Description

Every time it rains on Farmer John‘s fields, a pond forms over Bessie‘s favorite clover patch. This means that the clover is covered by water for awhile and takes quite a long time to regrow. Thus, Farmer John has built a set of drainage ditches so that Bessie‘s clover patch is never covered in water. Instead, the water is drained to a nearby stream. Being an ace engineer, Farmer John has also installed regulators at the beginning of each ditch, so he can control at what rate water flows into that ditch. 
Farmer John knows not only how many gallons of water each ditch can transport per minute but also the exact layout of the ditches, which feed out of the pond and into each other and stream in a potentially complex network. 
Given all this information, determine the maximum rate at which water can be transported out of the pond and into the stream. For any given ditch, water flows in only one direction, but there might be a way that water can flow in a circle. 

Input

The input includes several cases. For each case, the first line contains two space-separated integers, N (0 <= N <= 200) and M (2 <= M <= 200). N is the number of ditches that Farmer John has dug. M is the number of intersections points for those ditches. Intersection 1 is the pond. Intersection point M is the stream. Each of the following N lines contains three integers, Si, Ei, and Ci. Si and Ei (1 <= Si, Ei <= M) designate the intersections between which this ditch flows. Water will flow through this ditch from Si to Ei. Ci (0 <= Ci <= 10,000,000) is the maximum rate at which water will flow through the ditch.

Output

For each case, output a single integer, the maximum rate at which water may emptied from the pond.

Sample Input

5 4
1 2 40
1 4 20
2 4 20
2 3 30
3 4 10

Sample Output

50


#include"stdio.h"
#include"string.h"
#include"queue"
using namespace std;
#define N 205
const int inf=0x7fffffff;
int g[N][N];
int pre[N],mark[N];
int ek(int n)
{
    int i,u,d,ans=0;
    while(1)
    {
        queue<int>q;
        q.push(1);
        memset(mark,0,sizeof(mark));
        memset(pre,0,sizeof(pre));
        mark[1]=1;
        while(!q.empty())
        {
            u=q.front();
            q.pop();
            for(i=1;i<=n;i++)
            {
                if(!mark[i]&&g[u][i])
                {
                    mark[i]=1;
                    pre[i]=u;
                    q.push(i);
                }
            }
        }
        if(pre[n]==0)
            break;
        d=inf;
        for(i=n;i!=1;i=pre[i])
        {
            d=min(d,g[pre[i]][i]);
        }
        for(i=n;i!=1;i=pre[i])
        {
            g[pre[i]][i]-=d;
            g[i][pre[i]]+=d;
        }
        ans+=d;
    }
    return ans;
}
int main()
{
    int n,m,u,v,w;
    while(scanf("%d%d",&n,&m)!=-1)
    {
        memset(g,0,sizeof(g));
        while(n--)
        {
            scanf("%d%d%d",&u,&v,&w);
            g[u][v]+=w;
        }
        printf("%d\n",ek(m));
    }
    return 0;
}

hdu 1532 poj 1273 Drainage Ditches (最大流),布布扣,bubuko.com

hdu 1532 poj 1273 Drainage Ditches (最大流)

原文:http://blog.csdn.net/u011721440/article/details/38236571

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!