首页 > 其他 > 详细

hdu1159-Common Subsequence(DP:最长公共子序列LCS)

时间:2018-10-27 00:46:11      阅读:227      评论:0      收藏:0      [点我收藏+]

Common Subsequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 49216    Accepted Submission(s): 22664
Problem Description
A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = <x1, x2, ..., xm> another sequence Z = <z1, z2, ..., zk> is a subsequence of X if there exists a strictly increasing sequence <i1, i2, ..., ik> of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = <a, b, f, c> is a subsequence of X = <a, b, c, f, b, c> with index sequence <1, 2, 4, 6>. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y. 
The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line. 
Sample Input
abcfbc abfcab
programming
contest abcd mnp
Sample Output
4
2
0
 
Source

代码:

#include<iostream>
#include<string.h>
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
const int  maxnum = 1000 + 5;
int dp[maxnum][maxnum];
#define max(x,y){x>y?x:y}
void DP_LCS(char str1[], char str2[])
{
    memset(dp, 0, sizeof(dp));
    int i, j;
    for (i = 0; i < strlen(str1); i++)
    {
        for (j = 0; j < strlen(str2); j++)
        {
            if ( strlen(str1)==0 || strlen(str2) == 0)//边界情况:如果有个字符串长度为0
            {
                dp[i+1][j+1] = 0;//公共子序列为0
            }
            if (str1[i] == str2[j])//第一种情况:a[i]==b[j]  A的前i个,B的前j个;
            {
                dp[i+1][j+1] = dp[i][j] + 1;//直接加1
            }
            else//第二、三种情况 dp[i][j]=dp[i-1][j]||dp[i][j]=dp[i][j-1]  A的前i-1个,B的前j个;A的前i个,B的前j-1个;
            {
                dp[i+1][j+1] = max(dp[i][j+1], dp[i+1][j]);
            }
        }
    }
    cout<< dp[strlen(str1)][strlen(str2)]<<endl;
}
int main()
{
    char  str1[maxnum], str2[maxnum];
    int N;
    while (cin >> str1 >> str2)
    {
        DP_LCS(str1, str2);
    }
    return 0;
}

 

hdu1159-Common Subsequence(DP:最长公共子序列LCS)

原文:https://www.cnblogs.com/gcter/p/9859324.html

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!