首页 > 其他 > 详细

求奇数的乘积

时间:2014-07-29 21:48:42      阅读:558      评论:0      收藏:0      [点我收藏+]
Problem Description
给你n个整数,求他们中所有奇数的乘积。
 Input
输入数据包含多个测试实例,每个测试实例占一行,每行的第一个数为n,表示本组数据一共有n个,接着是n个整数,你可以假设每组数据必定至少存在一个奇数。
 Output
输出每组数中的所有奇数的乘积,对于测试实例,输出一行。
 Sample Input
3 1 2 3
4 2 3 4 5
 Sample Output
3
15
 
 
code:

#include<stdio.h>
int main()
{
      int n,i,a[100];
       while(scanf("%d",&n)!=EOF)                                                                                          error C2466: cannot allocate an array of constant size 0
        {                                                   不能在此int a[n];否则error C2133: ‘a‘ : unknown size;error C2057: expected constant expression;

              int s=1;
             for(i=0;i<n;i++)
            {
                scanf("%d",&a[i]);
                if(a[i]%2!=0)
                     s=s*a[i];
             }
         printf("%d\n",s);         //若掉\n则Presentation Error
}
return 0;
}

 

 
 

求奇数的乘积,布布扣,bubuko.com

求奇数的乘积

原文:http://www.cnblogs.com/gongpulin/p/3876374.html

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!