首页 > 其他 > 详细

HDOJ_1005_Number Sequence

时间:2018-11-28 10:17:49      阅读:148      评论:0      收藏:0      [点我收藏+]

找规律:(0,0),(0,1)......(6,6);每次a和b的值是一样的。找规律,每49一次循环。

 

Font Size:

Problem Description

A number sequence is defined as follows:
f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.
Given A, B, and n, you are to calculate the value of f(n).

Input

The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.

Output

For each test case, print the value of f(n) on a single line.

Sample Input

1 1 3
1 2 10
0 0 0

Sample Output

2
5

AC代码:
#include <iostream>
#include <cstdio>
using namespace std;
int main(void)
{
    freopen("in.txt","r",stdin);
    int a,b;
    long long n;
    while(scanf("%d%d%lld",&a,&b,&n)!=EOF&&(a||b||n))
    {
        int x[100];
        x[1]=1;
        x[2]=1;
        for(int i=3;i<=49;i++)
            x[i]=((a*x[i-1])%7 + (b*x[i-2])%7)%7; 
        
        printf("%d\n",x[n%49]);
    }
    
    fclose(stdin);
    return 0;
}

 

HDOJ_1005_Number Sequence

原文:https://www.cnblogs.com/phaLQ/p/10030083.html

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!