首页 > 其他 > 详细

hdu 1829 A Bug's Life(判断二分图)

时间:2014-07-31 20:48:27      阅读:316      评论:0      收藏:0      [点我收藏+]

A Bug‘s Life

Time Limit: 15000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 8528    Accepted Submission(s): 2745


Problem Description
Background 
Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy to identify, because numbers were printed on their backs. 

Problem 
Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it.
 

Input
The first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space. In the following lines, each interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.
 

Output
The output for every scenario is a line containing "Scenario #i:", where i is the number of the scenario starting at 1, followed by one line saying either "No suspicious bugs found!" if the experiment is consistent with his assumption about the bugs‘ sexual behavior, or "Suspicious bugs found!" if Professor Hopper‘s assumption is definitely wrong.
 

Sample Input
2 3 3 1 2 2 3 1 3 4 2 1 2 3 4
 

Sample Output
Scenario #1: Suspicious bugs found! Scenario #2: No suspicious bugs found!
Hint
Huge input,scanf is recommended.


利用黑白染色,判断是否是二分图。

#include"stdio.h"
#include"string.h"
#include"queue"
using namespace std;
#define N 2005
#define M 1000005
int n,m,t,head[N];
int color[N],flag;
struct node
{
    int u,v,next;
}map[2*M];
void add(int u,int v)
{
    map[t].u=u;
    map[t].v=v;
    map[t].next=head[u];
    head[u]=t++;
    map[t].u=v;
    map[t].v=u;
    map[t].next=head[v];
    head[v]=t++;
}
void find(int u)
{
    int i,v;
    for(i=head[u];i!=-1;i=map[i].next)
    {
        v=map[i].v;
        if(color[v]==-1)
        {
            color[v]=color[u]^1;
            find(v);
        }
        else if(color[v]==color[u])
        {
            flag=1;
            return ;
        }
    }
    return ;
}
int main()
{
    int i,T,u,v,cnt=1;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d",&n,&m);
        t=0;
        memset(head,-1,sizeof(head));
        while(m--)
        {
            scanf("%d%d",&u,&v);
            add(u,v);
        }
        memset(color,-1,sizeof(color));
        flag=0;
        for(i=1;i<=n;i++)
        {
            if(color[i]==-1)
            {
                color[i]=0;
                find(i);
                if(flag)
                    break;
            }
        }
        printf("Scenario #%d:\n",cnt++);
        if(flag)
            printf("Suspicious bugs found!\n");
        else
            printf("No suspicious bugs found!\n");
        puts("");
    }
    return 0;
}


hdu 1829 A Bug's Life(判断二分图),布布扣,bubuko.com

hdu 1829 A Bug's Life(判断二分图)

原文:http://blog.csdn.net/u011721440/article/details/38322713

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!