首页 > 其他 > 详细

POJ 2677 Tour

时间:2014-08-01 02:26:51      阅读:319      评论:0      收藏:0      [点我收藏+]

双调欧几里得 DP



Tour
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 3581   Accepted: 1596

Description

John Doe, a skilled pilot, enjoys traveling. While on vacation, he rents a small plane and starts visiting beautiful places. To save money, John must determine the shortest closed tour that connects his destinations. Each destination is represented by a point in the plane pi = < xi,yi >. John uses the following strategy: he starts from the leftmost point, then he goes strictly left to right to the rightmost point, and then he goes strictly right back to the starting point. It is known that the points have distinct x-coordinates. 
Write a program that, given a set of n points in the plane, computes the shortest closed tour that connects the points according to John‘s strategy.

Input

The program input is from a text file. Each data set in the file stands for a particular set of points. For each set of points the data set contains the number of points, and the point coordinates in ascending order of the x coordinate. White spaces can occur freely in input. The input data are correct.

Output

For each set of data, your program should print the result to the standard output from the beginning of a line. The tour length, a floating-point number with two fractional digits, represents the result. An input/output sample is in the table below. Here there are two data sets. The first one contains 3 points specified by their x and y coordinates. The second point, for example, has the x coordinate 2, and the y coordinate 3. The result for each data set is the tour length, (6.47 for the first data set in the given example).

Sample Input

3
1 1
2 3
3 1
4
1 1
2 3
3 1
4 2

Sample Output

6.47
7.89

Source

[Submit]   [Go Back]   [Status]   [Discuss]


#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>

using namespace std;

double x[100],y[100];

double dist(int a,int b)
{
	return sqrt((x[a]-x[b])*(x[a]-x[b])+(y[a]-y[b])*(y[a]-y[b]));
}

double dp[100][100];
int n;

int main()
{
	while(cin>>n)
	{
		for(int i=1;i<=n;i++)
		{
			cin>>x[i]>>y[i];
		}
		for(int i=0;i<=n;i++)
		{
			for(int j=0;j<=n;j++)
			{
				dp[i][j]=99999999;
			}
		}
		dp[1][1]=0; dp[2][1]=dist(1,2);
		for(int i=1;i<=n;i++)
		{
			for(int j=1;j<i;j++)
			{
				dp[i+1][j]=min(dp[i+1][j],dp[i][j]+dist(i+1,i));
				dp[i+1][i]=min(dp[i+1][i],dp[i][j]+dist(i+1,j));
			}
		}
		double ans=99999999;
		for(int j=1;j<n;j++)
			ans=min(ans,dp[n-1][j]+dist(j,n));
		printf("%.2f\n",ans+dist(n-1,n));
	}
	return 0;
}




POJ 2677 Tour,布布扣,bubuko.com

POJ 2677 Tour

原文:http://blog.csdn.net/ck_boss/article/details/38327113

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!