首页 > 其他 > 详细

PAT 甲级 1048 Find Coins

时间:2018-12-14 14:34:16      阅读:159      评论:0      收藏:0      [点我收藏+]

https://pintia.cn/problem-sets/994805342720868352/problems/994805432256675840

 

Eva loves to collect coins from all over the universe, including some other planets like Mars. One day she visited a universal shopping mall which could accept all kinds of coins as payments. However, there was a special requirement of the payment: for each bill, she could only use exactly two coins to pay the exact amount. Since she has as many as 10?5?? coins with her, she definitely needs your help. You are supposed to tell her, for any given amount of money, whether or not she can find two coins to pay for it.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive numbers: N (10?5??, the total number of coins) and M (10?3??, the amount of money Eva has to pay). The second line contains N face values of the coins, which are all positive numbers no more than 500. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the two face values V?1?? and V?2?? (separated by a space) such that V?1??+V?2??=M and V?1??V?2??. If such a solution is not unique, output the one with the smallest V?1??. If there is no solution, output No Solution instead.

Sample Input 1:

8 15
1 2 8 7 2 4 11 15

Sample Output 1:

4 11

Sample Input 2:

7 14
1 8 7 2 4 11 15

Sample Output 2:

No Solution
 

代码:

#include <bits/stdc++.h>
using namespace std;

const int maxn = 1e5 + 10;
int n, target;
int num[maxn];

int main() {
    scanf("%d%d", &n, &target);
    for(int i = 0; i < n; i ++)
        scanf("%d", &num[i]);
    sort(num, num + n);
    int l = 0, r = n - 1;
    int ans1 = -1, ans2 = -1;
    while(l < r) {
        if(num[l] + num[r] == target) {
            ans1 = l;
            ans2 = r;
            break;
        }
        if(num[l] + num[r] < target) l ++;
        if(num[l] + num[r] > target) r --;
    }
    if(ans1 == -1 && ans2 == -1)
        printf("No Solution\n");
    else
        printf("%d %d\n", num[ans1], num[ans2]);
    return 0;
}

  双指针 突然觉得刷 Leetcode 还是很有用的

PAT 甲级 1048 Find Coins

原文:https://www.cnblogs.com/zlrrrr/p/10119148.html

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!