首页 > 其他 > 详细

poj 2676

时间:2014-08-01 19:55:52      阅读:402      评论:0      收藏:0      [点我收藏+]
Sudoku
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 13665   Accepted: 6767   Special Judge

Description

Sudoku is a very simple task. A square table with 9 rows and 9 columns is divided to 9 smaller squares 3x3 as shown on the Figure. In some of the cells are written decimal digits from 1 to 9. The other cells are empty. The goal is to fill the empty cells with decimal digits from 1 to 9, one digit per cell, in such way that in each row, in each column and in each marked 3x3 subsquare, all the digits from 1 to 9 to appear. Write a program to solve a given Sudoku-task. 
bubuko.com,布布扣

Input

The input data will start with the number of the test cases. For each test case, 9 lines follow, corresponding to the rows of the table. On each line a string of exactly 9 decimal digits is given, corresponding to the cells in this line. If a cell is empty it is represented by 0.

Output

For each test case your program should print the solution in the same format as the input data. The empty cells have to be filled according to the rules. If solutions is not unique, then the program may print any one of them.

Sample Input

1
103000509
002109400
000704000
300502006
060000050
700803004
000401000
009205800
804000107

Sample Output

143628579
572139468
986754231
391542786
468917352
725863914
237481695
619275843
854396127

Source

Southeastern Europe 2005

AC代码:

#include<iostream>
using namespace std;
char G[15][15];
char ch[15]={'0','1','2','3','4','5','6','7','8','9'};
int a[15]={0,1,1,1,4,4,4,7,7,7};
int sucess;
int judge(int x,int y,int k){
	for(int i=1;i<=9;i++){
		if(G[x][i]==ch[k])
		    return 0;
	}
	for(int i=1;i<=9;i++){
		if(G[i][y]==ch[k])
		    return 0;
	}
	for(int i=a[x];i<=a[x]+2;i++)
	    for(int j=a[y];j<=a[y]+2;j++)
	        if(G[i][j]==ch[k])
	            return 0;
	return 1;
}
void dfs(int x,int y){
	if(sucess)
	    return ;
	if(x*y>81){
		for(int i=1;i<=9;i++){
		    for(int j=1;j<=9;j++)
		        cout<<G[i][j];
		    cout<<endl;
		}
		sucess=1;
		return ;
	}

	if(G[x][y]!='0'){
		if(y==9)
		    dfs(x+1,1);
		else
		    dfs(x,y+1);
	}
	else{
		for(int k=1;k<=9;k++){
			if(judge(x,y,k)){
				G[x][y]=ch[k];
				if(y==9)
		            dfs(x+1,1);
		        else
		            dfs(x,y+1);
		        G[x][y]='0';
			}
		}
	}

}
int main(){
	int T; cin>>T;
	while(T--){
		for(int i=1;i<=9;i++)
		    cin>>G[i]+1;
		sucess=0;
		dfs(1,1);
	}
	return 0;
}


poj 2676,布布扣,bubuko.com

poj 2676

原文:http://blog.csdn.net/my_acm/article/details/38338767

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!