All in All
Time Limit: 1000MS |
|
Memory Limit: 30000K |
Total Submissions: 27775 |
|
Accepted: 11413 |
Description
You have devised a new encryption technique which encodes a message by inserting between its characters randomly generated strings in a clever way. Because of pending patent issues we will not discuss in detail how the strings are generated and inserted into
the original message. To validate your method, however, it is necessary to write a program that checks if the message is really encoded in the final string.
Given two strings s and t, you have to decide whether s is a subsequence of t, i.e. if you can remove characters from t such that the concatenation of the remaining characters is s.
Input
The input contains several testcases. Each is specified by two strings s, t of alphanumeric ASCII characters separated by whitespace.The length of s and t will no more than 100000.
Output
For each test case output "Yes", if s is a subsequence of t,otherwise output "No".
Sample Input
sequence subsequence
person compression
VERDI vivaVittorioEmanueleReDiItalia
caseDoesMatter CaseDoesMatter
Sample Output
Yes
No
Yes
No
Source
Ulm Local 2002
题意为求判断t是否为s插入字符之后的字符串
AC代码:
#include<iostream>
#include<string>
#include<cstring>
#include<algorithm>
using namespace std;
string s,t;
int main(){
while(cin>>s>>t){
int i,j;
i=j=0;
while(j<t.length() && i<s.length()){
if(s[i]==t[j]){
i++;
j++;
}
else
j++;
}
if(i>=s.length())
cout<<"Yes"<<endl;
else
cout<<"No"<<endl;
}
return 0;
}
poj 1936,布布扣,bubuko.com
poj 1936
原文:http://blog.csdn.net/my_acm/article/details/38347419