首页 > 其他 > 详细

HDU 4906

时间:2014-08-02 18:18:03      阅读:336      评论:0      收藏:0      [点我收藏+]

Our happy ending

Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 570    Accepted Submission(s): 183


Problem Description
There is an old country and the king fell in love with a devil. The devil always asks the king to do some crazy things. Although the king used to be wise and beloved by his people. Now he is just like a boy in love and can’t refuse any request from the devil. Also, this devil is looking like a very cute Loli.

Y*wan still remember the day he first meets the devil. Now everything is done and the devil is gone. Y*wan feel very sad and suicide.

You feel guilty after killing so many loli, so you suicide too.

Nobody survive in this silly story, but there is still some hope, because this is just a silly background story during one programming contest!

And the last problem is:

Given a sequence a_1,a_2,...,a_n, if we can take some of them(each a_i can only be used once), and they sum to k, then we say this sequence is a good sequence.

How many good sequence are there? Given that each a_i is an integer and 0<= a_i <= L.

You should output the result modulo 10^9+7.
 

 

Input
The first line contains an integer T, denoting the number of the test cases.
For each test case, the first line contains 3 integers n, k, L.

T<=20, n,k<=20 , 0<=L<=10^9.
 

 

Output
For each cases, output the answer in a single line.
 

 

Sample Input
1 2 2 2
 

 

Sample Output
6


递推实现 f[i][j]表示前i个数能够表示j状态的方案数,其中j为最多20位的二进制,表示前i个数的和(1-20)是否达到 

 

bubuko.com,布布扣
#include "cstdio"
#include "cstring"
#define min(x,y) (x>y?y:x)

#define MOD 1000000007

int f[1050000];
int n,k,l;
int main()
{
    int tt;
    scanf("%d",&tt);
    while(tt--)
    {
        memset(f,0,sizeof(f));
        scanf("%d%d%d",&n,&k,&l);
        int ms=(1<<k)-1;
        long long ans=0;

        for(int j=0; j<=min(l,k); j++)
            f[1<<(j-1)]=1;
        if(l>k) f[0]=(f[0]+l-k)%MOD;

        for(int i=1; i<n; i++)
            for(int s=ms; s>=0; s--)
            if(f[s]>0)//
            {
                long long tmp=f[s];
                for(int j=1; j<=min(l,k); j++)
                {
                    int ns=(s|(s<<j)|(1<<(j-1)))&ms;
                    f[ns]=(f[ns]+tmp)%MOD;
                }
                if(l>k)
                    f[s]=(f[s]+(l-k)*tmp%MOD)%MOD;
            }

        for(int s=0; s<=ms; s++)
        if(s&(1<<(k-1)))
            ans=(ans+f[s])%MOD;

        printf("%lld\n",ans);
    }
    return 0;
}
View Code

 

 

超时代码:

bubuko.com,布布扣
#include "cstdio"
#include "cstring"
#define min(x,y) (x>y?y:x)
#define MOD 1000000007
int f[21][1050000],c[21][21];
int n,k,l;
inline long long pow(long long a, long long b)
{
    long long ret=1,tmp=a%MOD;
    while(b)
    {
        if(b&1) ret=(ret*tmp)%MOD;
        tmp=(tmp*tmp)%MOD;
        b>>=1;
    }
    return ret;
}
int main()
{
    for(int i=0; i<=20; i++)
        for(int j=0; j<=i; j++)
        if(j>0) c[i][j]=c[i-1][j]+c[i-1][j-1];
        else c[i][j]=1;
    int tt;
    scanf("%d",&tt);
    while(tt--)
    {
        memset(f,0,sizeof(f));
        scanf("%d%d%d",&n,&k,&l);
        int ms=(1<<k)-1;
        for(int j=0; j<=min(l,k); j++)
            f[1][1<<(j-1)]=1;
        for(int i=1; i<n; i++)
            for(int j=0; j<=min(l,k); j++)
                for(int s=0; s<=ms; s++)
                {
                    f[i+1][(s|(s<<j)|(1<<(j-1)))&ms]+=f[i][s];
                    f[i+1][(s|(s<<j)|(1<<(j-1)))&ms]%=MOD;
                }
        long long ans=0;
        if(l<=k)
        {
            for(int s=0; s<=ms; s++)
            if(s&(1<<(k-1)))
                ans=(ans+f[n][s])%MOD;
        }
        else
        {
            for(int i=1; i<=n; i++)
                for(int s=0; s<=ms; s++)
                if(s&(1<<(k-1)))
                    ans=(ans+((long long)f[i][s]*(long long)c[n][i])%MOD*pow(l-k,n-i))%MOD;
        }
        printf("%lld\n",ans);
    }
    return 0;
}
 
View Code

 

HDU 4906,布布扣,bubuko.com

HDU 4906

原文:http://www.cnblogs.com/Mathics/p/3887207.html

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!