首页 > 其他 > 详细

POJ 2395 Out of Hay

时间:2014-08-02 18:28:03      阅读:319      评论:0      收藏:0      [点我收藏+]

Out of Hay
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 11030   Accepted: 4320

Description

The cows have run out of hay, a horrible event that must be remedied immediately. Bessie intends to visit the other farms to survey their hay situation. There are N (2 <= N <= 2,000) farms (numbered 1..N); Bessie starts at Farm 1. She‘ll traverse some or all of the M (1 <= M <= 10,000) two-way roads whose length does not exceed 1,000,000,000 that connect the farms. Some farms may be multiply connected with different length roads. All farms are connected one way or another to Farm 1.

Bessie is trying to decide how large a waterskin she will need. She knows that she needs one ounce of water for each unit of length of a road. Since she can get more water at each farm, she‘s only concerned about the length of the longest road. Of course, she plans her route between farms such that she minimizes the amount of water she must carry.

Help Bessie know the largest amount of water she will ever have to carry: what is the length of longest road she‘ll have to travel between any two farms, presuming she chooses routes that minimize that number? This means, of course, that she might backtrack over a road in order to minimize the length of the longest road she‘ll have to traverse.

Input

* Line 1: Two space-separated integers, N and M.

* Lines 2..1+M: Line i+1 contains three space-separated integers, A_i, B_i, and L_i, describing a road from A_i to B_i of length L_i.

Output

* Line 1: A single integer that is the length of the longest road required to be traversed.

Sample Input

3 3
1 2 23
2 3 1000
1 3 43

Sample Output

43

Hint

OUTPUT DETAILS:

In order to reach farm 2, Bessie travels along a road of length 23. To reach farm 3, Bessie travels along a road of length 43. With capacity 43, she can travel along these roads provided that she refills her tank to maximum capacity before she starts down a road.

Source



题意:又是牛呗。出去旅行,旅行所带的水可以到一个交叉点接,但是Bessie很懒,他想带最少的水,他想知道他最多要嗲多少水,即求最长的一条路。

思路:求最小生成树的最大边。


#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cmath>
#include <cstring>
#include <stdlib.h>

using namespace std;

int mp[2005][2005];
int low[2005];
int vis[2005];
const int INF=1000000009;
int n,m;

int prim(){
    int pos,minx,res=-1;
    memset(vis,0,sizeof(vis));
    vis[1]=1;
    pos=1;
    for(int i=1;i<=n;i++){
        if(pos!=i)
            low[i]=mp[pos][i];
    }
    for(int i=1;i<n;i++){
        minx=INF;
        for(int j=1;j<=n;j++){
            if(!vis[j]&&minx>low[j]){
                minx=low[j];
                pos=j;
            }
        }
        if(res<minx)
            res=minx;
        vis[pos]=1;
        for(int j=1;j<=n;j++){
            if(!vis[j]&&low[j]>mp[pos][j])
                low[j]=mp[pos][j];
        }
    }
    return res;
}

int main(){
    scanf("%d%d",&n,&m);
    for(int i=1;i<=n;i++){
        for(int j=1;j<=n;j++){
            mp[i][j]=INF;
        }
    }
    for(int i=0;i<m;i++){
        int a,b,c;
        scanf("%d%d%d",&a,&b,&c);
        if(mp[a][b]>c)
            mp[a][b]=mp[b][a]=c;
    }
    printf("%d\n",prim());
}

POJ 2395 Out of Hay,布布扣,bubuko.com

POJ 2395 Out of Hay

原文:http://blog.csdn.net/kimi_r_17/article/details/38349317

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!