首页 > 其他 > 详细

POJ2230 Watchcow 【欧拉回路】+【DFS】

时间:2014-08-04 14:22:57      阅读:320      评论:0      收藏:0      [点我收藏+]

Watchcow
Time Limit: 3000MS   Memory Limit: 65536K
Total Submissions: 5964   Accepted: 2561   Special Judge

Description

Bessie‘s been appointed the new watch-cow for the farm. Every night, it‘s her job to walk across the farm and make sure that no evildoers are doing any evil. She begins at the barn, makes her patrol, and then returns to the barn when she‘s done. 

If she were a more observant cow, she might be able to just walk each of M (1 <= M <= 50,000) bidirectional trails numbered 1..M between N (2 <= N <= 10,000) fields numbered 1..N on the farm once and be confident that she‘s seen everything she needs to see. But since she isn‘t, she wants to make sure she walks down each trail exactly twice. It‘s also important that her two trips along each trail be in opposite directions, so that she doesn‘t miss the same thing twice. 

A pair of fields might be connected by more than one trail. Find a path that Bessie can follow which will meet her requirements. Such a path is guaranteed to exist.

Input

* Line 1: Two integers, N and M. 

* Lines 2..M+1: Two integers denoting a pair of fields connected by a path.

Output

* Lines 1..2M+1: A list of fields she passes through, one per line, beginning and ending with the barn at field 1. If more than one solution is possible, output any solution.

Sample Input

4 5
1 2
1 4
2 3
2 4
3 4

Sample Output

1
2
3
4
2
1
4
3
2
4
1

Hint

OUTPUT DETAILS: 

Bessie starts at 1 (barn), goes to 2, then 3, etc...

题意:给定n个点和m条路,求从1点出发每条路的两个方向都走一遍再回到原点的路径。
题解:
将无向图转换成有向图,DFS遍历整张图,每条边只能走一次。



#include <stdio.h>
#include <string.h>
#define maxn 10002
#define maxm 50002

int n, m;
int head[maxn];
bool vis[maxm << 1];
struct Node{
	int to, next;
} edge[maxm << 1];

void Init()
{
	memset(head, -1, sizeof(head));
	memset(vis, 0, sizeof(vis));
}

void GetEdge()
{
	int i, a, b;
	m <<= 1;
	for(i = 0; i < m; ++i){
		scanf("%d%d", &a, &b);
		edge[i].to = b;
		edge[i].next = head[a];
		head[a] = i++;
		edge[i].to = a;
		edge[i].next = head[b];
		head[b] = i;
	}
}

void DFS(int k)
{
	for(int i = head[k]; i != -1; i = edge[i].next){
		if(!vis[i]){
			vis[i] = 1;
			DFS(edge[i].to);
		}
	}
	printf("%d\n", k);
}
int main()
{
	int i;
	while(scanf("%d%d", &n, &m) == 2){
		Init();
		GetEdge();
		DFS(1);
	}
	return 0;
}


POJ2230 Watchcow 【欧拉回路】+【DFS】,布布扣,bubuko.com

POJ2230 Watchcow 【欧拉回路】+【DFS】

原文:http://blog.csdn.net/chang_mu/article/details/38367487

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!