首页 > 其他 > 详细

1050 String Subtraction (20 分)哈希 map

时间:2019-01-24 18:40:27      阅读:166      评论:0      收藏:0      [点我收藏+]
1050 String Subtraction (20 分)

Given two strings S?1?? and S?2??, S=S?1???S?2?? is defined to be the remaining string after taking all the characters in S?2?? from S?1??. Your task is simply to calculate S?1???S?2?? for any given strings. However, it might not be that simple to do it fast.

Input Specification:

Each input file contains one test case. Each case consists of two lines which gives S?1?? and S?2??, respectively. The string lengths of both strings are no more than 10?4??. It is guaranteed that all the characters are visible ASCII codes and white space, and a new line character signals the end of a string.

Output Specification:

For each test case, print S?1???S?2?? in one line.

Sample Input:

They are students.
aeiou

Sample Output:

Thy r stdnts.
#include<iostream>
#include<vector>
#include<algorithm>
#include<queue>
#include<string>
#include<map>
#include<set>
#include<stack>
#include<string.h>
#include<cstdio>
using namespace std;

map<char,int>mp;
char ch1[10005],ch2[10004];

int main()
{
    char ch;
    scanf("%c",&ch);
    int i,len1,len2;
    for(i=0; ch!=\n; i++)
    {
        ch1[i]=ch;
        mp[ch]=1;
        scanf("%c",&ch);

    }
    len1=i;
    scanf("%c",&ch);
    for(i=0; ch!=\n; i++)
    {
        ch2[i]=ch;
        mp[ch]=0;
        scanf("%c",&ch);
       // mp[ch]=1;

    }
    len2=i;
    for(int i=0; i<len1; i++)
    {
        if(mp[ch1[i]]==1)
            printf("%c",ch1[i]);
    }
    //cout<<len2<<len1;
    return 0;
}

 


1050 String Subtraction (20 分)哈希 map

原文:https://www.cnblogs.com/zhanghaijie/p/10315963.html

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!