首页 > 其他 > 详细

PAT 甲级 1085 Perfect Sequence

时间:2019-02-12 11:26:12      阅读:152      评论:0      收藏:0      [点我收藏+]

https://pintia.cn/problem-sets/994805342720868352/problems/994805381845336064

 

Given a sequence of positive integers and another positive integer p. The sequence is said to be a perfect sequence if Mm×p where M and m are the maximum and minimum numbers in the sequence, respectively.

Now given a sequence and a parameter p, you are supposed to find from the sequence as many numbers as possible to form a perfect subsequence.

Input Specification:

Each input file contains one test case. For each case, the first line contains two positive integers N and p, where N (10?5??) is the number of integers in the sequence, and p (10?9??) is the parameter. In the second line there are N positive integers, each is no greater than 10?9??.

Output Specification:

For each test case, print in one line the maximum number of integers that can be chosen to form a perfect subsequence.

Sample Input:

10 8
2 3 20 4 5 1 6 7 8 9

Sample Output:

8
 

代码:

    #include <bits/stdc++.h>
using namespace std;
 
const int maxn = 1e5 + 10;
long long a[maxn];
 
int main() {
    int N, p, temp = 1;
    scanf("%d%d", &N, &p);
    for(int i = 1; i <= N; i ++)
        scanf("%lld", &a[i]);
    sort(a + 1, a + 1 + N);
    for(int i = 1; i <= N; i ++) {
        for(int j = temp + i; j <= N; j ++) {
            if(a[j] <= a[i] * p)
                temp = j - i + 1;
            else break;
        }
    }
    printf("%d\n", temp);
    return 0;
}

  暴力 离考试越来越近 心慌慌

FH

PAT 甲级 1085 Perfect Sequence

原文:https://www.cnblogs.com/zlrrrr/p/10364351.html

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!