首页 > 其他 > 详细

Flutter 即学即用系列博客——01 环境搭建

时间:2019-02-12 20:20:38      阅读:70      评论:0      收藏:0      [点我收藏+]

标签:情况   ref   项目   警告   osi   net   升级版   别人   成功   

技术分享图片

前言

工欲善其事,必先利其器

所以第一篇我们来说说 Flutter 环境的搭建。

笔者这边使用的是 MAC 电脑,因此以 MAC 电脑的环境搭建为例。

Windows 或者 Linux 也是类似的操作。

Flutter 有英文版的官网和中文网,大家可以根据自己的喜好和情况进行选择。

点击下面的链接可以到对应的安装页面。
Flutter 官网安装链接
Flutter 中文网安装链接

我们这边以官网为例进行说明。

目录

技术分享图片

1. 配置镜像

点击进入官网,可以看到下图:

技术分享图片

我们点击 Using Flutter in China 进入:

技术分享图片

可以看到主要是让我们配置镜像站点。

所以我们就将要求的两个环境变量添加到系统就可以了。

打开 terminal,看下当前用户下面是否有 bash_profile 文件,执行命令:

vi ~/.bash_profile

如果底部有

"~/.bash_profile" [New File]

说明之前没有存在过这个文件。

不管之前是否存在过该文件,我们在末尾追加上面的两个环境变量即可。

如果不熟悉 vi 操作,可以参考下面两篇文章或者额外了解。
linux Vi操作和使用方法详解
Linux vi/vim

将上面两个环境变量添加到 bash_profile 文件,文件新增的两行应该类似下面(镜像地址可能有变动,以上面官网为主,笔者此刻就是下面的):

export PUB_HOSTED_URL=https://pub.flutter-io.cn  
export FLUTTER_STORAGE_BASE_URL=https://storage.flutter-io.cn

接着执行命令:

source ~/.bash_profile  
echo $PUB_HOSTED_URL

如果打印出了你输入的镜像,说明没有问题,设置成功了。

主要目的是追加两个环境变量,如果你习惯用文件打开,也可以打开文件后直接追加

回到安装页面,点击 macOS。

2. 获取 Flutter SDK

技术分享图片

从图中可以看到,当前的目标是获取 Flutter SDK。

点击蓝色按钮,下载 Flutter SDK。
下载完成之后解压到自己想放置的目录(建议路径不要包含中文)。

这里假设我们将压缩包解压到的路径为 ~/flutter。

首先把下载下来的压缩包移动到 ~/flutter。
我这边下载的压缩包为flutter_macos_v1.0.0-stable.zip,执行命令

unzip flutter_macos_v1.0.0-stable.zip

执行完成之后可以看到当前目录多了一个 flutter 文件夹。
接下来就是要把 flutter 设置到环境变量以便在任何地方都可以执行 flutter 命令。
执行如下命令:

cd flutter/  
pwd

控制窗口会打印 flutter 根目录。我这边为/Users/nesger/flutter/flutter。

跟上面设置两个环境变量操作类似,首先打开文件~/.bash_profile。
添加下面语句:

export FLUTTER_ROOT=/Users/nesger/flutter/flutter
export PATH=$FLUTTER_ROOT/bin:$PATH

这里定义了 flutter 根目录并将其下面的 bin 目录设置到 PATH 里面。
保存退出后执行

source ~/.bash_profile

NOTE:执行该命令后你当前窗口和新开的窗口就都可以直接运行 flutter 命令了。但是之前开的窗口就不可以了。如果需要之前的窗口也可以,就需要在对应窗口执行上面的 source ~/.bash_profile 命令

3. 执行 flutter doctor 完善相关工具链

运行

flutter doctor

会打印 flutter 需要的工具链是否完善。(NOTE: 这个命令后面会多次用到)

技术分享图片

可以看出一些端倪。
显示一些警告。
按照上面提示进行处理即可。

举个例子:

? Android licenses not accepted.  To resolve this, run: flutter doctor --android-licenses

这边说 Android licenses 没有 accepted,执行

flutter doctor --android-licenses

然后不断点击 y 表示同意就可以了。

我们运行之后,再使用

flutter doctor

可以看到已经修复了

技术分享图片

接下来就是 iOS toolchain 以及 Android Studio 两个插件的安装。
对于 Android 开发来说,其实 iOS toolchain 不修复也没问题。
我们先修复 flutter 插件安装。

NOTE:Android Studio 版本需要 3.0 或者更高版本,不然会有坑,这边为了演示一下坑及遇到的解决方法。所以这边先用版本 2.3.3 进行演示。读者最好先升级版本到 3.0。步骤是一样的。

第一步:Android Studio->Preferences
技术分享图片
第二步:点击左侧 Plugins
技术分享图片
第三步:输入 flutter,点击 Search in repositories
技术分享图片
第四步:点击 Install
技术分享图片
第五步:dart 一起安装
技术分享图片

安装完成之后重启 Android Studio,然后在终端执行命令

flutter doctor

技术分享图片

可以看到 Flutter 插件安装好了,只不过这里提示版本不够新。
如果你的 Android Studio 版本为 3.0 或者更高,就不会报错,那么可以忽略下面的修复步骤。

修复步骤:
重启 Android Studio 并没有看到直接创建 Flutter 项目。
笔者这边 Android Studio 版本为 2.3.3。
而 Flutter 需要 Android Studio 3.0 或者更高版本支持。
这边更新 Android Studio 之后重启。
可以看到执行 flutter doctor 命令之后 Android Studio 确实是 3.3 版本了。

技术分享图片

但是 Flutter 依然不是最新的,需要到 plugins 去更新。
此外,还需要更新 dart。
更新完之后就可以看到创建 Flutter 项目了。

技术分享图片

到了这里基本上对于 Android 开发的你来说环境搭建就完成了。

技术分享图片

4. 扩展

可以看到上面有个 iOS toolchain,基于下面几点,我想修复这个。

  1. 我的机器安装了 Xcode。
  2. 刚接触 Flutter,想多点尝试,也想看看 Flutter 代码在 iOS 运行效果。
  3. 听说 iOS 开发都用模拟器,想体验下 iOS 模拟器。
    Android 的模拟器大家都懂,反正我大部分是用真机调试。

所以按照上面的提示,Xcode 完全安装以及运行相应命令。
但是遇到了一个坑,就是依然报错。
所以我直接将提示的命令一步执行,结果可以了。

在 GitHub 上面还帮助到了一个 iOS 开发者。
flutter doctor 提示 iOS toolchain 有些错误

更多环境搭建问题和解决方案大家都可以提 issue 哦~
也许别人刚好就解决了你遇到的问题
Flutter Issue 集合

技术分享图片

Flutter 即学即用系列博客——01 环境搭建

标签:情况   ref   项目   警告   osi   net   升级版   别人   成功   

原文:https://www.cnblogs.com/nesger/p/10366903.html

(0)
(0)
   
举报
评论 一句话评论(0
0条  
登录后才能评论!
© 2014 bubuko.com 版权所有 鲁ICP备09046678号-4
打开技术之扣,分享程序人生!
             

鲁公网安备 37021202000002号