首页 > 其他 > 详细

PAT 甲级 1096 Consecutive Factors

时间:2019-02-15 13:02:11      阅读:166      评论:0      收藏:0      [点我收藏+]

https://pintia.cn/problem-sets/994805342720868352/problems/994805370650738688

 

Among all the factors of a positive integer N, there may exist several consecutive numbers. For example, 630 can be factored as 3×5×6×7, where 5, 6, and 7 are the three consecutive numbers. Now given any positive N, you are supposed to find the maximum number of consecutive factors, and list the smallest sequence of the consecutive factors.

Input Specification:

Each input file contains one test case, which gives the integer N (1<N<).

Output Specification:

For each test case, print in the first line the maximum number of consecutive factors. Then in the second line, print the smallest sequence of the consecutive factors in the format factor[1]*factor[2]*...*factor[k], where the factors are listed in increasing order, and 1 is NOT included.

Sample Input:

630

Sample Output:

3
5*6*7

代码:

#include <bits/stdc++.h>
using namespace std;

int N;

int main() {
    scanf("%d", &N);
    for(int i = 13; i >= 1; i --) {
        for(int j = 2; j * j <= N; j ++) {
            long long ans = 1;
            for(int k = j; k - j <= i - 1; k ++)
                ans *= k;

            if(N % ans == 0) {
                printf("%d\n%d", i, j);
                for(int k = j + 1; k - j <= i - 1; k ++)
                    printf("*%d", k);

                return 0;
            }
        }
    }
    printf("1\n%d", N);
    return 0;
}

  枚举连续因子长度 枚举起点终点

FH

PAT 甲级 1096 Consecutive Factors

原文:https://www.cnblogs.com/zlrrrr/p/10382881.html

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!