首页 > 其他 > 详细

POJ2256 ZOJ1945 UVA537 Artificial Intelligence?【文本】

时间:2019-02-16 00:07:40      阅读:206      评论:0      收藏:0      [点我收藏+]

Artificial Intelligence?
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 1585 Accepted: 719

Description

Physics teachers in high school often think that problems given as text are more demanding than pure computations. After all, the pupils have to read and understand the problem first!
So they don‘t state a problem like "U=10V, I=5A, P=?" but rather like "You have an electrical circuit that contains a battery with a voltage of U=10V and a light-bulb. There‘s an electrical current of I=5A through the bulb. Which power is generated in the bulb?".
However, half of the pupils just don‘t pay attention to the text anyway. They just extract from the text what is given: U=10V, I=5A. Then they think: "Which formulae do I know? Ah yes, P=UI. Therefore P=10V5A=500W. Finished."
OK, this doesn‘t always work, so these pupils are usually not the top scorers in physics tests. But at least this simple algorithm is usually good enough to pass the class. (Sad but true.)
Today we will check if a computer can pass a high school physics test. We will concentrate on the P-U-I type problems first. That means, problems in which two of power, voltage and current are given and the third is wanted.

Your job is to write a program that reads such a text problem and solves it according to the simple algorithm given above.

Input

The first line of the input will contain the number of test cases.
Each test case will consist of one line containing exactly two data fields and some additional arbitrary words. A data field will be of the form I=xA, U=xV or P=xW, where x is a real number. Directly before the unit (A,V or W) one of the prefixes m (milli), k (kilo) and M (Mega) may also occur. To summarize it: Data fields adhere to the following grammar:
DataField ::= Concept ‘=‘ RealNumber [Prefix] Unit
Concept ::= ‘P‘ | ‘U‘ | ‘I‘

Prefix ::= ‘m‘ | ‘k‘ | ‘M‘

Unit ::= ‘W‘ | ‘V‘ | ‘A‘

Additional assertions:
The equal sign (‘=‘) will never occur in an other context than within a data field.
There is no whitespace (tabs,blanks) inside a data field.
Either P and U, P and I, or U and I will be given.

Output

For each test case, print three lines:
a line saying "Problem #k" where k is the number of the test case
a line giving the solution (voltage, power or current, dependent on what was given), written without a prefix and with two decimal places as shown in the sample output
a blank line

Sample Input

3
If the voltage is U=200V and the current is I=4.5A, which power is generated?
A light-bulb yields P=100W and the voltage is U=220V. Compute the current, please.
bla bla bla lightning strike I=2A bla bla bla P=2.5MW bla bla voltage?

Sample Output

Problem #1
P=900.00W

Problem #2
I=0.45A

Problem #3
U=1250000.00V

Source

Ulm Local 1998

问题链接POJ2256 ZOJ1945 UVA537 Artificial Intelligence?
问题简述:(略)
问题分析
????这是一个文本处理问题,按部就班处理即可。关键是程序需要写得简洁。
????代码中的函数atof()的用法值得推荐。
程序说明:(略)
参考链接:(略)
题记:(略)

AC的C++语言程序如下:

/* POJ2256 ZOJ1945 UVA537 Artificial Intelligence? */

#include <iostream>
#include <stdlib.h>
#include <stdio.h>

using namespace std;

string s;

double ufind(char *p)
{
    double res = 1;
    while(*p) {
        if(*p == 'A' || *p =='V' || *p =='W')
            break;
        if(*p == 'm')
            res /= 1000;
        else if(*p == 'k')
            res *= 1000;
        else if(*p == 'M')
            res *= 1000000;
        p++;
    }
    return res;
}

int main()
{
    int t, caseno = 0;
    cin >> t;
    getline(cin, s);
    while(t--) {
        getline(cin, s);
        int pos1 = s.find("U=");
        int pos2 = s.find("I=");
        int pos3 = s.find("P=");
        printf("Problem #%d\n", ++caseno);
        if(pos1 == (int)string::npos) {
            double ans = atof(&s[pos3] + 2) / atof(&s[pos2] + 2);
            double unit3 = ufind(&s[pos3] + 2);
            double unit2 = ufind(&s[pos2] + 2);
            printf("U=%.2fV\n", ans * unit3 / unit2);
        } else if(pos2 == (int)string::npos) {
            double ans = atof(&s[pos3] + 2) / atof(&s[pos1] + 2);
            double unit3 = ufind(&s[pos3] + 2);
            double unit1 = ufind(&s[pos1] + 2);
            printf("I=%.2fA\n", ans * unit3 / unit1);
        } else {
            double ans = atof(&s[pos1] + 2) * atof(&s[pos2] + 2);
            double unit1 = ufind(&s[pos1] + 2);
            double unit2 = ufind(&s[pos2] + 2);
            printf("P=%.2fW\n", ans * unit1 * unit2);
        }
        printf("\n");
    }

    return 0;
}

POJ2256 ZOJ1945 UVA537 Artificial Intelligence?【文本】

原文:https://www.cnblogs.com/tigerisland45/p/10386423.html

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!