首页 > 其他 > 详细

hdu 4920 Matrix multiplication

时间:2014-08-05 19:21:30      阅读:297      评论:0      收藏:0      [点我收藏+]

Matrix multiplication

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 334    Accepted Submission(s): 112


Problem Description
Given two matrices A and B of size n×n, find the product of them.

bobo hates big integers. So you are only asked to find the result modulo 3.
 

Input
The input consists of several tests. For each tests:

The first line contains n (1≤n≤800). Each of the following n lines contain n integers -- the description of the matrix A. The j-th integer in the i-th line equals Aij. The next n lines describe the matrix B in similar format (0≤Aij,Bij≤109).
 

Output
For each tests:

Print n lines. Each of them contain n integers -- the matrix A×B in similar format.
 

Sample Input
1 0 1 2 0 1 2 3 4 5 6 7
 

Sample Output
0 0 1 2 1
 

Author
Xiaoxu Guo (ftiasch)
 

Source
 



题解及代码:


/*
签到题,简单的矩阵相乘,注意元素0的处理就不会超时了。
*/
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
const int mod=3;
int a[810][810],b[810][810];
int temp[810][810];
void multiple(int n,int p)
{
    int i,j,k;
    for(i=0; i<n; i++)
        for(j=0; j<n; j++)
        {
            if(a[i][j]!=0)
                for(k=0; k<n; k++)
                    temp[i][k]=(temp[i][k]+a[i][j]*b[j][k])%p;
        }
    for(int i=0;i<n;i++)
    {
        for(int j=0;j<n;j++)
            if(j==0) printf("%d",temp[i][j]);
        else printf(" %d",temp[i][j]);
        puts("");
    }
}



void init(int n)
{
   memset(temp,0,sizeof(temp));
   for(int i=0;i<n;i++)
   {
       for(int j=0;j<n;j++)
       {
          scanf("%d",&a[i][j]);
          a[i][j]%=3;
       }
   }
   for(int i=0;i<n;i++)
   {
       for(int j=0;j<n;j++)
       {
          scanf("%d",&b[i][j]);
          b[i][j]%=3;
       }
   }
}

int main()
{
    int n;
    while(cin>>n)
    {
        init(n);
        multiple(n,mod);
    }
    return 0;
}


hdu 4920 Matrix multiplication,布布扣,bubuko.com

hdu 4920 Matrix multiplication

原文:http://blog.csdn.net/knight_kaka/article/details/38388777

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!