首页 > 其他 > 详细

POJ 2388 Who's in the Middle

时间:2014-08-06 11:56:11      阅读:303      评论:0      收藏:0      [点我收藏+]

/*
中文题意:给你一个奇数n(odd number),让你求出这n个数的中位数
题目大意:如上
关键点:求出中位数的位置,sort排序
解题人:lingnichong
解题时间:2014/08/06    11:10
解题感受:求中位数的位置,水题一道
*/


Who‘s in the Middle
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 31597   Accepted: 18378

Description

FJ is surveying his herd to find the most average cow. He wants to know how much milk this ‘median‘ cow gives: half of the cows give as much or more than the median; half give as much or less. 

Given an odd number of cows N (1 <= N < 10,000) and their milk output (1..1,000,000), find the median amount of milk given such that at least half the cows give the same amount of milk or more and at least half give the same or less.

Input

* Line 1: A single integer N 

* Lines 2..N+1: Each line contains a single integer that is the milk output of one cow.

Output

* Line 1: A single integer that is the median milk output.

Sample Input

5
2
4
1
3
5

Sample Output

3


#include<stdio.h>
#include<algorithm>
using namespace std;
#define MAXN 1000000+10
int a[MAXN];
int main()
{
	int N,i;
	while(~scanf("%d",&N))
	{
		for(i  = 0; i < N; i++)
			scanf("%d",&a[i]);
		sort(a,a+N);
		printf("%d\n",a[(N-1)/2]);
	}
	return 0;
} 


POJ 2388 Who's in the Middle,布布扣,bubuko.com

POJ 2388 Who's in the Middle

原文:http://blog.csdn.net/qq_16767427/article/details/38398073

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!