首页 > 其他 > 详细

POJ 3006 Dirichlet's Theorem on Arithmetic Progressions

时间:2014-08-06 11:59:51      阅读:720      评论:0      收藏:0      [点我收藏+]

Dirichlet‘s Theorem on Arithmetic Progressions
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 15714   Accepted: 7887

Description

If a and d are relatively prime positive integers, the arithmetic sequence beginning with a and increasing by d, i.e., aa + da + 2da + 3da + 4d, ..., contains infinitely many prime numbers. This fact is known as Dirichlet‘s Theorem on Arithmetic Progressions, which had been conjectured by Johann Carl Friedrich Gauss (1777 - 1855) and was proved by Johann Peter Gustav Lejeune Dirichlet (1805 - 1859) in 1837.

For example, the arithmetic sequence beginning with 2 and increasing by 3, i.e.,

2, 5, 8, 11, 14, 17, 20, 23, 26, 29, 32, 35, 38, 41, 44, 47, 50, 53, 56, 59, 62, 65, 68, 71, 74, 77, 80, 83, 86, 89, 92, 95, 98, ... ,

contains infinitely many prime numbers

2, 5, 11, 17, 23, 29, 41, 47, 53, 59, 71, 83, 89, ... .

Your mission, should you decide to accept it, is to write a program to find the nth prime number in this arithmetic sequence for given positive integers ad, and n.

Input

The input is a sequence of datasets. A dataset is a line containing three positive integers ad, and n separated by a space. a and d are relatively prime. You may assume a <= 9307, d <= 346, and n <= 210.

The end of the input is indicated by a line containing three zeros separated by a space. It is not a dataset.

Output

The output should be composed of as many lines as the number of the input datasets. Each line should contain a single integer and should never contain extra characters.

The output integer corresponding to a dataset adn should be the nth prime number among those contained in the arithmetic sequence beginning with a and increasing by d.

FYI, it is known that the result is always less than 106 (one million) under this input condition.

Sample Input

367 186 151
179 10 203
271 37 39
103 230 1
27 104 185
253 50 85
1 1 1
9075 337 210
307 24 79
331 221 177
259 170 40
269 58 102
0 0 0

Sample Output

92809
6709
12037
103
93523
14503
2
899429
5107
412717
22699
25673

Source


题目大意 :

输入三个数a,b,n.表示以a为首项,b为公差的等差数列中的素数序列,求出第n个序列中的素数。


#include <iostream>
#include <math.h>
#include <string>
using namespace std;
int main()
{	
	int a,d,n;
	while(cin>>a>>d>>n&&(a||d||n))
	{
		int i,j,k=1,sushu[100001];
		int m;
		for(i=a;i<=1000001;i=i+d)
		{
			m=int(sqrt((double)i)); 
			for(j=2;j<=m;j++)
			{
				if(i%j==0)
					break;
			}
			if(j>m&&i!=1)
			{
				sushu[k]=i;
				if(k==n)
					break;
				k++;
			}
		}
		cout<<sushu[n]<<endl;
	}
	return 0;
	
}








POJ 3006 Dirichlet's Theorem on Arithmetic Progressions,布布扣,bubuko.com

POJ 3006 Dirichlet's Theorem on Arithmetic Progressions

原文:http://blog.csdn.net/sunshumin/article/details/38397427

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!