首页 > 其他 > 详细

HDU1213 How Many Tables 【并查集】

时间:2014-08-06 19:02:32      阅读:389      评论:0      收藏:0      [点我收藏+]

How Many Tables

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 13360    Accepted Submission(s): 6539


Problem Description
Today is Ignatius‘ birthday. He invites a lot of friends. Now it‘s dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.
 

Input
The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.
 

Output
For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.
 

Sample Input
2 5 3 1 2 2 3 4 5 5 1 2 5
 

Sample Output
2 4
用并查集判断有多少棵树。

#include <stdio.h>
#include <string.h>
#define maxn 1002

int pre[maxn];

int unionFind(int a)
{
	int b = a;
	while(pre[a] != -1) a = pre[a];
	int k;
	while(b != a){
		k = pre[b];
		pre[b] = a;
		b = k;
	}
	return a;
}

int main()
{
	int n, m, t, a, b, ans;
	scanf("%d", &t);
	while(t--){
		scanf("%d%d", &n, &m);
		memset(pre, -1, sizeof(pre));
		ans = n;
		while(m--){
			scanf("%d%d", &a, &b);
			a = unionFind(a);
			b = unionFind(b);
			if(a != b){
				--ans; pre[a] = b;
			}
		}
		printf("%d\n", ans);
	}
	return 0;
}


HDU1213 How Many Tables 【并查集】,布布扣,bubuko.com

HDU1213 How Many Tables 【并查集】

原文:http://blog.csdn.net/chang_mu/article/details/38405001

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!