首页 > 其他 > 详细

hdu 1022 Train Problem I

时间:2014-08-07 18:24:43      阅读:296      评论:0      收藏:0      [点我收藏+]

Train Problem I

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 20497    Accepted Submission(s): 7701


Problem Description
As the new term comes, the Ignatius Train Station is very busy nowadays. A lot of student want to get back to school by train(because the trains in the Ignatius Train Station is the fastest all over the world ^v^). But here comes a problem, there is only one railway where all the trains stop. So all the trains come in from one side and get out from the other side. For this problem, if train A gets into the railway first, and then train B gets into the railway before train A leaves, train A can‘t leave until train B leaves. The pictures below figure out the problem. Now the problem for you is, there are at most 9 trains in the station, all the trains has an ID(numbered from 1 to n), the trains get into the railway in an order O1, your task is to determine whether the trains can get out in an order O2.
bubuko.com,布布扣bubuko.com,布布扣bubuko.com,布布扣
 

 

Input
The input contains several test cases. Each test case consists of an integer, the number of trains, and two strings, the order of the trains come in:O1, and the order of the trains leave:O2. The input is terminated by the end of file. More details in the Sample Input.
 

 

Output
The output contains a string "No." if you can‘t exchange O2 to O1, or you should output a line contains "Yes.", and then output your way in exchanging the order(you should output "in" for a train getting into the railway, and "out" for a train getting out of the railway). Print a line contains "FINISH" after each test case. More details in the Sample Output.
 

 

Sample Input
3 123 321 3 123 312
 

 

Sample Output
Yes. in in in out out out FINISH No. FINISH
Hint
Hint
For the first Sample Input, we let train 1 get in, then train 2 and train 3. So now train 3 is at the top of the railway, so train 3 can leave first, then train 2 and train 1. In the second Sample input, we should let train 3 leave first, so we have to let train 1 get in, then train 2 and train 3. Now we can let train 3 leave. But after that we can‘t let train 1 leave before train 2, because train 2 is at the top of the railway at the moment. So we output "No.".
 
#include <stdio.h>
#include <stack>
#include <string.h>
using namespace std;

const char ch[2][4] = {"in", "out"};
int main()
{
    stack<char> s;
    char s1[105], s2[105], t;
    int n, i, j, k, ans[210];
    while (~scanf("%d%s%s", &n, s1, s2))
    {
        while (!s.empty())
        {
            s.pop();
        }
        memset(ans, 0, sizeof(ans));
        i = j = k = 0;
        while (i < n)
        {
            s.push(s1[i]);
            k++;
            while (!s.empty())
            {
                t = s.top();
                if (t == s2[j])
                {
                    s.pop();
                    ans[k++] = 1;
                    j++;
                }
                else
                    break;    
            }    
            i++;    
        }
        while (!s.empty() && j < n)
        {
            t = s.top();
            if (t == s2[j])
            {
                s.pop();
                ans[k++] = 1;
                j++;
            }
            else
                break;    
        }
        if (j == n)
        {
            puts("Yes.");
            for (i = 0; i < k; i++)
                puts(ch[ans[i]]);
        }
        else
        {
            puts("No.");
        }
        puts("FINISH");
    }
    return 0;
}

 

hdu 1022 Train Problem I,布布扣,bubuko.com

hdu 1022 Train Problem I

原文:http://www.cnblogs.com/jecyhw/p/3897530.html

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!