首页 > 系统服务 > 详细

【转载】failed to initialize nvml driver/library version mismatch ubuntu

时间:2019-03-22 19:50:30      阅读:599      评论:0      收藏:0      [点我收藏+]

标签:mat   pro   错误   ==   margin   nload   cal   hit   font   

技术分享图片

英伟达驱动版本是384.130

技术分享图片

显示的NVRM version: NVIDIA UNIX x86_64 Kernel Module是:384.130。 若是旧的版本就会出现如下问题。

这个问题出现的原因是kernel mod 的 Nvidia driver 的版本没有更新,一般情况下,重启机器就能够解决,如果因为某些原因不能够重启的话,也有办法reload kernel mod。

方法如下:

 

就两步

  1. unload nvidia kernel mod
  2. reload nvidia kernel mod

执行

  1. sudo rmmod nvidia
  2. sudo nvidia-smi

若出现问题

  1. $ sudo rmmod nvidia
  2. rmmod: ERROR: Module nvidia is in use by: nvidia_modeset nvidia_uvm

这时,就要一点一点的卸载整个驱动了,首先要知道现在kernel mod 的依赖情况,首先我们从错误信息中知道,nvidia_modeset nvidia_uvm 这两个 mod 依赖于 nvidia, 所以要先卸载他们

技术分享图片

 

先查看下有哪些进程使用了 nvidia*

```

sudo fuser -v /dev/nvidia* #查找占用GPU资源的PID

sudo lsof -n -w /dev/nvidia* #查找占用GPU资源的PID

```

技术分享图片

这些进程有个了解,如果一会卸载失败,记得关闭相关进程。

卸载

  1. sudo rmmod nvidia_uvm
  2. sudo rmmod nvidia_modeset

 

 

 

#参考文献

解决Driver/library version mismatch

NVIDIA驱动问题解决方案:Failed to initialize NVML: driver/library version mismatch

【转载】failed to initialize nvml driver/library version mismatch ubuntu

标签:mat   pro   错误   ==   margin   nload   cal   hit   font   

原文:https://www.cnblogs.com/JsonZhangAA/p/10580551.html

(0)
(0)
   
举报
评论 一句话评论(0
© 2014 bubuko.com 版权所有 鲁ICP备09046678号-4
打开技术之扣,分享程序人生!
             

鲁公网安备 37021202000002号