首页 > 移动平台 > 详细

2014 Multi-University Training Contest 6 Apple Tree(数学题)

时间:2014-08-07 23:18:35      阅读:442      评论:0      收藏:0      [点我收藏+]

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=4925

Apple Tree

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 176    Accepted Submission(s): 120

Problem Description
I’ve bought an orchard and decide to plant some apple trees on it. The orchard seems like an N * M two-dimensional map. In each grid, I can either plant an apple tree to get one apple or fertilize the soil to speed up its neighbors’ production. When a grid is fertilized, the grid itself doesn’t produce apples but the number of apples of its four neighbor trees will double (if it exists). For example, an apple tree locates on (x, y), and (x - 1, y), (x, y - 1) are fertilized while (x + 1, y), (x, y + 1) are not, then I can get four apples from (x, y). Now, I am wondering how many apples I can get at most in the whole orchard?
 
Input
The input contains multiple test cases. The number of test cases T (T<=100) occurs in the first line of input.
For each test case, two integers N, M (1<=N, M<=100) are given in a line, which denote the size of the map.
 
Output
For each test case, you should output the maximum number of apples I can obtain.
 
Sample Input
2 2 2 3 3
 
Sample Output
8 32
 
Source


代码如下:

#include <cstdio>
#include <cstring> 
int mp[217][217];
int main()
{
    int t;
    int n,i,a,ans,k,er,m,j;
    while(scanf("%d",&t)!=EOF)
    {
        while(t--)
        {
            scanf("%d%d",&n,&m);
            memset(mp,0,sizeof(mp));
			if(n == 1 && m == 1)
			{
				printf("1\n");
				continue;
			}
            for(i = 1; i <= n; i++)
            {
                for(j = 1; j <= m; j++)
                {
                    if((i+j)&1)
                        mp[i][j]=1;
                }
            }
            ans=0;
            for(i = 1; i <= n; i++)
            {
                for(j = 1; j <= m; j++)
                {
                    if(mp[i][j] == 0)
                    {
                        if(mp[i-1][j])
                        {
                            mp[i-1][j]*=2;
                        }
                        if(mp[i][j-1])
                        {
                            mp[i][j-1]*=2;
                        }
                        if(mp[i][j+1])
                        {        
                            mp[i][j+1]*=2;
                        }
                        if(mp[i+1][j])
                        {
                            mp[i+1][j]*=2;
                        }
                    }
                    
                }
            }
            for(i = 1; i <= n; i++)
            {
                for(j = 1; j <= m; j++)
                {
                    if(mp[i][j])
                        ans+=mp[i][j];
                }
            }
            
            printf("%d\n",ans);
        }
    }
    return 0;
}



2014 Multi-University Training Contest 6 Apple Tree(数学题),布布扣,bubuko.com

2014 Multi-University Training Contest 6 Apple Tree(数学题)

原文:http://blog.csdn.net/u012860063/article/details/38424663

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!