/*首字母变大写
Input
输入数据包含多个测试实例,每个测试实例是一个长度不超过100的英文句子,占一行。
Output
请输出按照要求改写后的英文句子。
Sample Input
i like acm
i want to get an accepted
Sample Output
I Like Acm
I Want To Get An Accepted
*/
#include<stdio.h>
#include<ctype.h>
#include<string.h>
int main()
{
char a[110];
int len,i;
while(gets(a)!=NULL)
{
len=strlen(a);
a[0]=toupper(a[0]);//toupper函数是将小写字母转换成大写字母,tolower函数是将大写字母转换成小写字母。
for(i=1;i<len;i++)
{
if(a[i-1]==‘ ‘&&a[i]!=‘ ‘)
a[i]=toupper(a[i]);
}
puts(a);//gets从这一地址开始依次输出存储单元中的字符,遇到第一个‘\0‘符号时结束输出,并自动换行 。
}
return 0;
}
原文:http://blog.csdn.net/hdd871532887/article/details/38434119