首页 > 其他 > 详细

PAT 1001 A+B Format

时间:2019-04-07 00:32:44      阅读:137      评论:0      收藏:0      [点我收藏+]
1001 A+B Format (20 分)
 

Calculate a+b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification:

Each input file contains one test case. Each case contains a pair of integers a and b where −. The numbers are separated by a space.

Output Specification:

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:

-1000000 9

Sample Output:

-999,991

#include<iostream>
#include<cstring>
#include<string>
#include<vector>
#include<bits/stdc++.h>
using namespace std;
typedef long long ll;

int main(){
    ll a,b;
    cin >> a >> b;
    ll c = a+b;
    if(c == 0){cout << 0;return 0;}
    if(c<0){
        cout << "-";
        c = -c;
    }

    vector<int> vec;

    int cnt = 0;
    while(c){
        if(cnt%3 == 0)vec.push_back(-1);
        vec.push_back(c%10);
        c = c/10;
        cnt++;
    }


    for(int i=vec.size()-1;i>0;i--){
        if(vec[i]==-1)cout << ",";
        else cout << vec[i];
    }

//    for(auto num:vec) cout << num << " ";



    return 0;
}

都用leetcode风格写,nice!

 

PAT 1001 A+B Format

原文:https://www.cnblogs.com/cunyusup/p/10663767.html

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!