首页 > 其他 > 详细

PAT 1046 Shortest Distance

时间:2019-04-13 22:37:28      阅读:116      评论:0      收藏:0      [点我收藏+]
1046 Shortest Distance (20 分)
 

The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.

Input Specification:

Each input file contains one test case. For each case, the first line contains an integer N (in [3]), followed by N integer distances D?1?? D?2?? D?N??, where D?i??is the distance between the i-th and the (-st exits, and D?N?? is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (≤), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 1.

Output Specification:

For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.

Sample Input:

5 1 2 4 14 9
3
1 3
2 5
4 1

Sample Output:

3
10
7
#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
#define MAXN 100005

int a[MAXN];
ll dis[MAXN] = {0};



int main(){
    int n;cin >> n;
    ll sum = 0;
    for(int i=0;i < n;i++){
        cin >> a[i];sum+=a[i];
        dis[i+1] = sum;
    }
    int t;cin >> t;
    int cnt = 0;
    while(t--){

        int x,y;cin >> x >> y;
        if(x == y){cout << 0 << endl;continue;}
        if(x > y)swap(x,y);
        ll sum1 = dis[y-1] - dis[x-1];

        ll sum2 = dis[x-1] - dis[0] + dis[n] - dis[y-1];

        cout << min(sum1,sum2) << endl;

    }
    return 0;
}

两点之间距离是距0的距离之差,线段树和树状数组差不多就这个性质吧。

 

PAT 1046 Shortest Distance

原文:https://www.cnblogs.com/cunyusup/p/10703129.html

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!