首页 > 其他 > 详细

PAT 1050 String Subtraction

时间:2019-04-13 23:35:47      阅读:115      评论:0      收藏:0      [点我收藏+]
1050 String Subtraction (20 分)
 

Given two strings S?1?? and S?2??, S=S?1??S?2?? is defined to be the remaining string after taking all the characters in S?2?? from S?1??. Your task is simply to calculate S?1??S?2?? for any given strings. However, it might not be that simple to do it fast.

Input Specification:

Each input file contains one test case. Each case consists of two lines which gives S?1?? and S?2??, respectively. The string lengths of both strings are no more than 1. It is guaranteed that all the characters are visible ASCII codes and white space, and a new line character signals the end of a string.

Output Specification:

For each test case, print S?1??S?2?? in one line.

Sample Input:

They are students.
aeiou

Sample Output:

Thy r stdnts.
#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
#define MAXN 10005

map<char,int> mp;
vector<char> vec;


int main(){
    string s1,s2;
    getline(cin,s1);
    getline(cin,s2);

    for(int i=0;i < s2.size();i++){
        mp[s2[i]]++;
    }


    for(int i=0;i < s1.size();i++){
        if(!mp[s1[i]]) cout << s1[i];
    }
    return 0;
}

——

 

PAT 1050 String Subtraction

原文:https://www.cnblogs.com/cunyusup/p/10703361.html

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!