首页 > 编程语言 > 详细

win64位系统+Anacond(python3.6)避坑快速安装Dlib+Face_recognition

时间:2019-04-14 23:54:05      阅读:206      评论:0      收藏:0      [点我收藏+]

标签:新版   -i   ==   spa   cond   分享图片   ont   tle   csdn   

      最近对人脸识别感兴趣,于是入坑安装Face_recognition,花一天功夫没装下来,我的系统和Python版本是win64+Anacond(python3.7.1)。

       一天下来搞明白了想安装face_recongnition的必需配置好Dlib, 配置好dlib的必要条件是:自己安装一次dlib,并且编译,还要安装巨大的VS,安装Dlib的配置好boost和cmake,一直在摸索不安装VS就想把其他都安装好,一直都是出错。终于在睡觉前微信搜索到一篇博文在python3.6下可成功安装Face_recognition,第二天花了十来分钟就安装成功,主要的时间花在准备上,现在把我刨坑经验告诉大家。

一、准备工作

1、安装Python3.6

     有关的知识网上很多,自行百度,我这里偷懒也找了一篇近似文章(anaconda中更改python版本),然后打开终端,我新建的环境名字就叫face3.6,终端的名字也是这个名字,留着终端不要关。以下指令都是在这个终端输入的技术分享图片   技术分享图片

2、升级pip,新环境的pip版本很低,需要升级到最新版本。 在终端输入以下指令升级到 pip-19.0.3

 python -m pip install --upgrade pip             

 准备工作就只有这样简单2步,如果你安装的不是Anacond版本,你直接安装Python3.6版本也是可以的

二、安装Dlib

pip install -i  https://pypi.tuna.tsinghua.edu.cn/simple dlib==19.7.0  

用清华的镜像安装19.7.0 版本 的 dlib,这个很重要,不加这个版本号可能不能安装成功,即使安装成功在接下来安装face_recognition也会失败。

三、安装face_recognition

pip install -i https://pypi.tuna.tsinghua.edu.cn/simple face_recognition

安装速度非常快,不到2分钟就成功安装完了!

四、安装python3.6版本下的spyder开发环境的安装

画蛇添足的说在新环境下安装spyder

pip install -i https://pypi.tuna.tsinghua.edu.cn/simple spyder

安装后会显示多一个spyder(face3.6)

 

win64位系统+Anacond(python3.6)避坑快速安装Dlib+Face_recognition

标签:新版   -i   ==   spa   cond   分享图片   ont   tle   csdn   

原文:https://www.cnblogs.com/thyuan/p/10708242.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 bubuko.com 版权所有 鲁ICP备09046678号-4
打开技术之扣,分享程序人生!
             

鲁公网安备 37021202000002号