首页 > 其他 > 详细

UVA - 10312 Expression Bracketing

时间:2014-08-10 15:47:00      阅读:313      评论:0      收藏:0      [点我收藏+]

Description

bubuko.com,布布扣

Problem A

Expression Bracketing

Input: standard input

Output: standard output

Time Limit: 1 second

Memory Limit: 32 MB

 

Inthis problem you will have to find in how many ways n letters can be bracketed so that the bracketing is non-binarybracketing. For example 4 lettershave 11 possible bracketing:

 

xxxx, (xx)xx, x(xx)x, xx(xx),(xxx)x, x(xxx), ((xx)x)x, (x(xx))x, (xx)(xx), x((xx)x), x(x(xx)). Of these the first sixbracketing are not binary. Given the number of letters you will have to findthe total number of non-binary bracketing.

 

Input

Theinput file contains several lines of input. Each line contains a single integern (0<n<=26). Input isterminated by end of file.

 

Output

For each line of input produce one line of outputwhich denotes the number of non binary bracketing with n letters.

 

Sample Input

3

4

5

10

 

Sample Output

1

6

31

98187

题意:如果p,q是要求的串,那么(p,q)也满足,求所有不可能的条件

思路:我们先求满足的,可以想象的到,这个跟卡特兰数的思路是类似的,都是将串分成(1, n-1), (2, n-2)....考虑的,但是所有的情况可能就难求了,了解后是个叫

Super Catalan Number    的序列,相减求结果,但是注意卡特兰数都从0开始的

#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
typedef long long ll;
using namespace std;
const int maxn = 30;

int n;
ll catalan[maxn], supper[maxn];

void init() {
	supper[0] = supper[1] = supper[2] = 1;
	for (int i = 3; i < maxn; i++) 
		supper[i] = (3*(2*i-3)*supper[i-1] - (i-3)*supper[i-2])/i;
	catalan[0] = catalan[1] = 1;
	catalan[2] = 2;
	catalan[3] = 5;
	for (int i = 4; i < maxn; i++) 
		for (int j = 0; j < i; j++)
			catalan[i] += catalan[j] * catalan[i-j-1];
}

int main() {
	init();
	while (scanf("%d", &n) != EOF) {
		printf("%lld\n", supper[n]-catalan[n-1]);
	}
	return 0;
}



UVA - 10312 Expression Bracketing,布布扣,bubuko.com

UVA - 10312 Expression Bracketing

原文:http://blog.csdn.net/u011345136/article/details/38469925

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!