首页 > 其他 > 详细

POJ 2013 Symmetric Order

时间:2014-08-11 17:54:22      阅读:313      评论:0      收藏:0      [点我收藏+]
B - Symmetric Order(3.3.1)
Time Limit:1000MS     Memory Limit:30000KB     64bit IO Format:%I64d & %I64u

Description

In your job at Albatross Circus Management (yes, it‘s run by a bunch of clowns), you have just finished writing a program whose output is a list of names in nondescending order by length (so that each name is at least as long as the one preceding it). However, your boss does not like the way the output looks, and instead wants the output to appear more symmetric, with the shorter strings at the top and bottom and the longer strings in the middle. His rule is that each pair of names belongs on opposite ends of the list, and the first name in the pair is always in the top part of the list. In the first example set below, Bo and Pat are the first pair, Jean and Kevin the second pair, etc. 

Input

The input consists of one or more sets of strings, followed by a final line containing only the value 0. Each set starts with a line containing an integer, n, which is the number of strings in the set, followed by n strings, one per line, sorted in nondescending order by length. None of the strings contain spaces. There is at least one and no more than 15 strings per set. Each string is at most 25 characters long.

Output

For each input set print "SET n" on a line, where n starts at 1, followed by the output set as shown in the sample output.

Sample Input

7
Bo
Pat
Jean
Kevin
Claude
William
Marybeth
6
Jim
Ben
Zoe
Joey
Frederick
Annabelle
5
John
Bill
Fran
Stan
Cece
0

Sample Output

SET 1
Bo
Jean
Claude
Marybeth
William
Kevin
Pat
SET 2
Jim
Zoe
Frederick
Annabelle
Joey
Ben
SET 3
John
Fran
Cece
Stan
Bill
题目大意:给出以长度非递减的顺序输出姓名列表。老板要求改成看上去对称的方式输出,即最短的字符串在顶部和底部,最长的在中间。他的规则是每一对姓名在列表对等的地方,每一对姓名中的第一个在上方。

 

#include <iostream>
#include <string>
#include <cstring>
using namespace std;
int main()
{
	int c=1;
	int n;
	while(cin>>n&&n)
	{
		string a[20];
		int i;
		for(i=1;i<=n;i++)
			cin>>a[i];
		cout<<"SET "<<c<<endl;
		if(n%2==0)
		{
			for(i=1;i<=n;i=i+2)
				cout<<a[i]<<endl;
			for(i=n;i>=1;i=i-2)
				cout<<a[i]<<endl;
		}
		else
		{
			for(i=1;i<=n;i=i+2)
				cout<<a[i]<<endl;
			for(i=n-1;i>=1;i=i-2)
				cout<<a[i]<<endl;
		}
		c++;
	}
	return 0;
}

/*
6
Jim
Ben
Zoe
Joey
Frederick
Annabelle
*/


 

 

POJ 2013 Symmetric Order,布布扣,bubuko.com

POJ 2013 Symmetric Order

原文:http://blog.csdn.net/sunshumin/article/details/38494829

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!