首页 > 其他 > 详细

POJ 2955 Brackets 区间DP

时间:2019-05-20 21:30:51      阅读:81      评论:0      收藏:0      [点我收藏+]

Brackets

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 14462   Accepted: 7595

Description

We give the following inductive definition of a “regular brackets” sequence:

  • the empty sequence is a regular brackets sequence,
  • if s is a regular brackets sequence, then (s) and [s] are regular brackets sequences, and
  • if a and b are regular brackets sequences, then ab is a regular brackets sequence.
  • no other sequence is a regular brackets sequence

For instance, all of the following character sequences are regular brackets sequences:

(), [], (()), ()[], ()[()]

while the following character sequences are not:

(, ], )(, ([)], ([(]

Given a brackets sequence of characters a1a2 … an, your goal is to find the length of the longest regular brackets sequence that is a subsequence of s. That is, you wish to find the largest m such that for indices i1i2, …, im where 1 ≤ i1i2 < … < im ≤ nai1ai2 … aim is a regular brackets sequence.

Given the initial sequence ([([]])], the longest regular brackets subsequence is [([])].

Input

The input test file will contain multiple test cases. Each input test case consists of a single line containing only the characters ()[, and ]; each input test will have length between 1 and 100, inclusive. The end-of-file is marked by a line containing the word “end” and should not be processed.

Output

For each input case, the program should print the length of the longest possible regular brackets subsequence on a single line.

Sample Input

((()))
()()()
([]])
)[)(
([][][)
end

Sample Output

6
6
4
0
6
题意:
给你由(,),[,]组成的字符串,从中取出一子串,问最大的括号匹配数?

分析:
求解DP的问题要从三个方面出发:子问题+最优解+极限状态。

设dp[i][j]表示字符串str[i]~str[j]的最大匹配数。

子问题:
(1)外层括号可以包含内层括号,所以当str[i],str[j]匹配时,dp[i][j] = dp[i+1][j-1] + 2;
(2)dp[i][j] 可以被分为很多不同的段的解的和值,即dp[i][j] = dp[i][k]+dp[k+1][j];

最优解:
dp[i][j] 为上面所有情况的最大值。

极限状态:
长度为1时:dp[i][i] = 0; 然后从长度为2~n开始递推出所有解。

#include<iostream>
#include<string.h>
#include<string>
#include<math.h>
using namespace std;
string s;
int dp[105][105];
int main()
{
    while(cin>>s)
    {
        if(s=="end")
            break;
        memset(dp,0,sizeof(dp));
        int n=s.length();
        for(int len=2;len<=n;len++)//枚举区间长度
        {
            for(int i=0;i+len<=n;i++)//枚举区间左端点
            {
                int j=i+len-1;//区间右端点
                if(j>n)//防止越界
                    break;
                if(s[i]==(&&s[j]==)||s[i]==[&&s[j]==])//如果第i个和第j个匹配
                    dp[i][j]=max(dp[i][j],dp[i+1][j-1]+2);
                for(int k=i;k<j;k++)//如果第 i 个和第 j 个不匹配,枚举中间分割点k
                    dp[i][j]=max(dp[i][j],dp[i][k]+dp[k+1][j]);
            }
        }
        cout<<dp[0][n-1]<<endl;
    }
}
 

 

POJ 2955 Brackets 区间DP

原文:https://www.cnblogs.com/-citywall123/p/10896480.html

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!