首页 > 其他 > 详细

1005 Spell It Right

时间:2019-05-21 23:43:44      阅读:126      评论:0      收藏:0      [点我收藏+]
1005 Spell It Right
 

Given a non-negative integer N, your task is to compute the sum of all the digits of N, and output every digit of the sum in English.

Input Specification:

Each input file contains one test case. Each case occupies one line which contains an N (≤).

Output Specification:

For each test case, output in one line the digits of the sum in English words. There must be one space between two consecutive words, but no extra space at the end of a line.

Sample Input:

12345

Sample Output:

one five


这是签到题目把?
import java.util.*;

public class Main{
    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);
        String str = sc.next();
        sc.close();
        int res = 0;
        for(int i=0;i<str.length();i++)
            res+=Integer.valueOf(str.charAt(i)-48);
        String result = String.valueOf(res);
        for(int i=0;i<result.length();i++) {
            switch(result.charAt(i)) {
            case 0:
                System.out.print("zero");
                break;
            case 1:
                System.out.print("one");
                break;
            case 2:
                System.out.print("two");
                break;
            case 3:
                System.out.print("three");
                break;
            case 4:
                System.out.print("four");
                break;
            case 5:
                System.out.print("five");
                break;
            case 6:
                System.out.print("six");
                break;
            case 7:
                System.out.print("seven");
                break;
            case 8:
                System.out.print("eight");
                break;
            case 9:
                System.out.print("nine");
                break;
            }
            if(i!=result.length()-1) System.out.print(" ");
        }
    }
}

 

技术分享图片

 

1005 Spell It Right

原文:https://www.cnblogs.com/godoforange/p/10903186.html

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!