首页 > 其他 > 详细

Large Division(大数取余模板)

时间:2019-06-04 16:35:29      阅读:142      评论:0      收藏:0      [点我收藏+]

Given two integers, a and b, you should check whether a is divisible by b or not. We know that an integer a is divisible by an integer b if and only if there exists an integer c such that a = b * c.

Input

Input starts with an integer T (≤ 525), denoting the number of test cases.

Each case starts with a line containing two integers a (-10200 ≤ a ≤ 10200) and b (|b| > 0, b fits into a 32 bit signed integer). Numbers will not contain leading zeroes.

Output

For each case, print the case number first. Then print ‘divisible‘ if a is divisible by b. Otherwise print ‘not divisible‘.

Sample Input

6

101 101

0 67

-101 101

7678123668327637674887634 101

11010000000000000000 256

-202202202202000202202202 -101

Sample Output

Case 1: divisible

Case 2: divisible

Case 3: divisible

Case 4: not divisible

Case 5: divisible

Case 6: divisible

 

模板题,记录一下

#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
char a[1000];
int main()
{
	int t,n,i;
	cin>>t;
	int h = 0;
	while(t--){
		ll b,ans = 0;
		cin>>a>>b;
		if(b < 0){
			b = -b;
		}
		for(i = 0; i < strlen(a); i++){
			if(a[0] == ‘-‘){
				a[i] = ‘0‘;
			}
			ans = (ans*10+(a[i]-‘0‘))%b;
		}
		if(ans == 0){
			printf("Case %d: divisible\n",++h); 
		}
		else{
			printf("Case %d: not divisible\n",++h);
		}
	}
	return 0;
} 

  

Large Division(大数取余模板)

原文:https://www.cnblogs.com/clb123/p/10973834.html

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!