首页 > 其他 > 详细

POJ 1804 Eqs

时间:2014-08-12 17:05:34      阅读:308      评论:0      收藏:0      [点我收藏+]

 

C - Eqs
Time Limit:5000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u

Description

Consider equations having the following form: 
a1x13+ a2x23+ a3x33+ a4x43+ a5x53=0 
The coefficients are given integers from the interval [-50,50]. 
It is consider a solution a system (x1, x2, x3, x4, x5) that verifies the equation, xi∈[-50,50], xi != 0, any i∈{1,2,3,4,5}. 

Determine how many solutions satisfy the given equation. 

Input

The only line of input contains the 5 coefficients a1, a2, a3, a4, a5, separated by blanks.

Output

The output will contain on the first line the number of the solutions for the given equation.

Sample Input

37 29 41 43 47

Sample Output

654

 

#include <iostream>
#include <cstring>
using namespace std;

#define maxn 25000005
short int hash[maxn];

int main()
{
    int a,b,c,d,e;
    while(cin>>a>>b>>c>>d>>e)
    {
        memset(hash,0,sizeof(hash));

        int i1,i2,i3,i4,i5;
        int sum=0;
        for(i1=-50;i1<=50;i1++)
        if(i1)
            for(i2=-50;i2<=50;i2++)
            if(i2)
            {
                sum=a*i1*i1*i1+b*i2*i2*i2;
                if(sum<0)
                    sum=sum+maxn;

                hash[sum]++;
            }

        int num=0;

        for(i3=-50;i3<=50;i3++)
        if(i3)
            for(i4=-50;i4<=50;i4++)
            if(i4)
                for(i5=-50;i5<=50;i5++)
                if(i5)
                {
                    sum=c*i3*i3*i3+d*i4*i4*i4+e*i5*i5*i5;
                    sum=-sum;

                    if(sum<0)
                        sum=sum+maxn;

                    if(hash[sum]!=0)
                        num=num+hash[sum];
                }

        cout<<num<<endl;
    }
    return 0;
}



 

 

 

 

POJ 1804 Eqs,布布扣,bubuko.com

POJ 1804 Eqs

原文:http://blog.csdn.net/sunshumin/article/details/38517725

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!