首页 > 其他 > 详细

hdu 4730 We Love MOE Girls

时间:2014-08-13 19:08:37      阅读:354      评论:0      收藏:0      [点我收藏+]

                  We Love MOE Girls

Time Limit: 1000/500 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1105    Accepted Submission(s): 674


Problem Description
Chikami Nanako is a girl living in many different parallel worlds. In this problem we talk about one of them.
In this world, Nanako has a special habit. When talking with others, she always ends each sentence with "nanodesu".
There are two situations:
If a sentence ends with "desu", she changes "desu" into "nanodesu", e.g. for "iloveyoudesu", she will say "iloveyounanodesu". Otherwise, she just add "nanodesu" to the end of the original sentence.
Given an original sentence, what will it sound like aften spoken by Nanako?
 

Input
The first line has a number T (T <= 1000) , indicating the number of test cases.
For each test case, the only line contains a string s, which is the original sentence.
The length of sentence s will not exceed 100, and the sentence contains lowercase letters from a to z only.
 

Output
For every case, you should output "Case #t: " at first, without quotes. The t is the case number starting from 1. Then output which Nanako will say.
 

Sample Input
2 ohayougozaimasu daijyoubudesu
 

Sample Output
Case #1: ohayougozaimasunanodesu Case #2: daijyoubunanodesu
 

Source
题意:水题。额,只要看最后几位是否满足这种情况,如果不满足的话直接加上这个字符。否则将前面几个字符给删掉,然后继续加。
#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
using namespace std;
int main()
{
    int t,i,j;
    string s;
    int step=1;
    scanf("%d",&t);
    while(t--)
    {
        cin>>s;
        int len=s.length();
        if(len>=4&&s[len-4]=='d'&&s[len-3]=='e'&&s[len-2]=='s'&&s[len-1]=='u')
        {
            s[len-4]='n';
            s[len-3]='a';
            s[len-2]='n';
            s[len-1]='o';
            s+="desu";
        }
        else
            s+="nanodesu";
            cout<<"Case #"<<step<<": "<<s<<endl;
        step++;
    }
    return 0;
}


hdu 4730 We Love MOE Girls,布布扣,bubuko.com

hdu 4730 We Love MOE Girls

原文:http://blog.csdn.net/chaoyueziji123/article/details/38537051

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!