Background
Hugo Heavy is happy. After the breakdown of the Cargolifter
project he can now expand business. But he needs a clever man who tells
him whether there really is a way from the place his customer has build
his giant steel crane to the place where it is needed on which all
streets can carry the weight.
Fortunately he already has a plan of the city with all
streets and bridges and all the allowed weights.Unfortunately he has no
idea how to find the the maximum weight capacity in order to tell his
customer how heavy the crane may become. But you surely know.
Problem
You are given the plan of the city, described by the streets
(with weight limits) between the crossings, which are numbered from 1 to
n. Your task is to find the maximum weight that can be transported from
crossing 1 (Hugo‘s place) to crossing n (the customer‘s place). You may
assume that there is at least one path. All streets can be travelled in
both directions.
Input
The first line contains the number of scenarios (city plans). For
each city the number n of street crossings (1 <= n <= 1000) and
number m of streets are given on the first line. The following m lines
contain triples of integers specifying start and end crossing of the
street and the maximum allowed weight, which is positive and not larger
than 1000000. There will be at most one street between each pair of
crossings.
Output
The output for every scenario begins with a line containing
"Scenario #i:", where i is the number of the scenario starting at 1.
Then print a single line containing the maximum allowed weight that Hugo
can transport to the customer. Terminate the output for the scenario
with a blank line.
Sample Input
1
3 3
1 2 3
1 3 4
2 3 5
Sample Output
Scenario #1:
4
题意:求n = 1的点到 n = n 的所有可达路径中(当前路径权值最小的)最大值,spfa算法如下:
//
// Created by hanyu on 2019/7/14.
//
#include<iostream>
#include<algorithm>
#include<queue>
#include<map>
#include<cstring>
#include<cstdio>
#include<math.h>
using namespace std;
typedef long long ll;
#define MAX 0x3f3f3f3f
const int maxn=1005;
int d[maxn];
int weight[maxn][maxn];
bool book[maxn];
int n;
void spfa(int a)
{
queue<int>qu;
while(!qu.empty()){
qu.pop();
}
memset(d,0,sizeof(d));
memset(book,false,sizeof(book));
book[a]=true;
d[a]=MAX;
qu.push(a);
int now;
while(!qu.empty())
{
now=qu.front();
qu.pop();
book[now]=false;
for(int i=1;i<=n;i++)
{
if(d[i]<min(d[now],weight[now][i]))
{
d[i]=min(d[now],weight[now][i]);
if(!book[i])
{
qu.push(i);
book[i]=true;
}
}
}
}
}
int main()
{
int T,x,y,z,m,num=0;
scanf("%d",&T);
while(T--)
{
scanf("%d%d",&n,&m);
memset(weight,0,sizeof(weight));
for(int i=1;i<=m;i++)
{
scanf("%d%d%d",&x,&y,&z);
weight[x][y]=weight[y][x]=z;
}
spfa(1);
num++;
printf("Scenario #%d:\n",num);
printf("%d\n\n",d[n]);
}
return 0;
}