首页 > 其他 > 详细

HDU - 4952 Number Transformation

时间:2014-08-14 20:39:59      阅读:242      评论:0      收藏:0      [点我收藏+]
Problem Description
Teacher Mai has an integer x.

He does the following operations k times. In the i-th operation, x becomes the least integer no less than x, which is the multiple of i.

He wants to know what is the number x now.
 

Input
There are multiple test cases, terminated by a line "0 0".

For each test case, the only one line contains two integers x,k(1<=x<=10^10, 1<=k<=10^10).
 

Output
For each test case, output one line "Case #k: x", where k is the case number counting from 1.
 

Sample Input
2520 10 2520 20 0 0
 

Sample Output
Case #1: 2520 Case #2: 2600 题意:给你个x,k次操作,对于第i次操作是:要找个nx,使得nx是>=x的最小值,且能整除i,求k次操作后的数 bubuko.com,布布扣
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
typedef __int64 ll;
using namespace std;

ll x, k;

int main() {
	int cas = 1;
	while (scanf("%I64d%I64d", &x, &k) != EOF && x+k) {
		ll tmp = x;
		for (ll i = 2; i <= k; i++) {
			tmp = tmp - tmp/i;
			if (tmp < i)
				break;
		}
		printf("Case #%d: %I64d\n", cas++, tmp*k);
	}
	return 0;
}


HDU - 4952 Number Transformation,布布扣,bubuko.com

HDU - 4952 Number Transformation

原文:http://blog.csdn.net/u011345136/article/details/38562543

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!