首页 > 其他 > 详细

POJ 2975 Nim

时间:2019-08-11 01:26:07      阅读:97      评论:0      收藏:0      [点我收藏+]

Description

Nim is a 2-player game featuring several piles of stones. Players alternate turns, and on his/her turn, a player’s move consists of removing one or more stones from any single pile. Play ends when all the stones have been removed, at which point the last player to have moved is declared the winner. Given a position in Nim, your task is to determine how many winning moves there are in that position.

A position in Nim is called “losing” if the first player to move from that position would lose if both sides played perfectly. A “winning move,” then, is a move that leaves the game in a losing position. There is a famous theorem that classifies all losing positions. Suppose a Nim position contains n piles having k1, k2, …, kn stones respectively; in such a position, there are k1 + k2 + … + kn possible moves. We write each ki in binary (base 2). Then, the Nim position is losing if and only if, among all the ki’s, there are an even number of 1’s in each digit position. In other words, the Nim position is losing if and only if the xor of the ki’s is 0.

Consider the position with three piles given by k1 = 7, k2 = 11, and k3 = 13. In binary, these values are as follows:

 111
1011
1101

There are an odd number of 1’s among the rightmost digits, so this position is not losing. However, suppose k3 were changed to be 12. Then, there would be exactly two 1’s in each digit position, and thus, the Nim position would become losing. Since a winning move is any move that leaves the game in a losing position, it follows that removing one stone from the third pile is a winning move when k1 = 7, k2 = 11, and k3 = 13. In fact, there are exactly three winning moves from this position: namely removing one stone from any of the three piles.

Input

The input test file will contain multiple test cases, each of which begins with a line indicating the number of piles, 1 ≤ n ≤ 1000. On the next line, there are n positive integers, 1 ≤ ki ≤ 1, 000, 000, 000, indicating the number of stones in each pile. The end-of-file is marked by a test case with n = 0 and should not be processed.

Output

For each test case, write a single line with an integer indicating the number of winning moves from the given Nim position.

Sample Input

3
7 11 13
2
1000000000 1000000000
0

Sample Output

3
0

Source

 
思路定理: NIM博弈先手必胜,当且仅当A1^ A2^ A3^ …… ^ An ≠ 0
证明:
所有物品都被取光是一个必败局面,此时 A1^ A2^ A3^ …… ^ An = 0
对于任意一个局面,如果A1^ A2^ A3^ …… ^ An =x (x≠ 0)
设x的二进制表示下最高位的1在第k位,那么至少存在一堆石子Ai,它的第k位是1。
显然Ai ^ x<Ai,这样我们就从Ai堆中取走若干石子,使其变为Ai^x,这样我们就得到了一
个各堆石子异或后等于0的局面。
相反对于任意一个局面,如果A1 ^ A2 ^ A3 ^ …… ^ An = 0
那么无论怎么取石子,得到的局面都是各堆石子异或起来不为0的情况(用反证法)
代码:
#include<cmath>
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;

const int N=1010;

int ans;
int a[N];
int n,sum;

int main () {
	scanf("%d",&n);
	while(n!=0) {
		sum=0,ans=0;
		for(int i=1; i<=n; i++) {
			scanf("%d",&a[i]);
			sum^=a[i];
		}
		for(int i=1; i<=n; i++)
			if((a[i]^sum)<a[i])
				ans++;
		printf("%d\n",ans);
		scanf("%d",&n);
	}
	return 0;
}

 

POJ 2975 Nim

原文:https://www.cnblogs.com/mysh/p/11333206.html

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!