首页 > 其他 > 详细

poj 1742 Coins

时间:2019-08-15 19:36:56      阅读:108      评论:0      收藏:0      [点我收藏+]
Coins

Time Limit: 3000MS Memory Limit: 30000K
Total Submissions: 48194 Accepted: 16209

Description

  People in Silverland use coins.They have coins of value A1,A2,A3...An Silverland dollar.One day Tony opened his money-box and found there were some coins.He decided to buy a very nice watch in a nearby shop. He wanted to pay the exact price(without change) and he known the price would not more than m.But he didn‘t know the exact price of the watch. 
  You are to write a program which reads n,m,A1,A2,A3...An and C1,C2,C3...Cn corresponding to the number of Tony‘s coins of value A1,A2,A3...An then calculate how many prices(form 1 to m) Tony can pay use these coins. 

Input

  The input contains several test cases. The first line of each test case contains two integers n(1<=n<=100),m(m<=100000).The second line contains 2n integers, denoting A1,A2,A3...An,C1,C2,C3...Cn (1<=Ai<=100000,1<=Ci<=1000). The last test case is followed by two zeros.

Output

   For each test case output the answer on a single line.

Sample Input

3 10
1 2 4 2 1 1
2 5
1 4 2 1
0 0

Sample Output

8
4

题意:有n种钱币,每种有技术分享图片个,价值为技术分享图片,求这些钱币能凑出多少种小于等于m的金额。

题解:男人八题之一怎么可能用直接的多重背包就能解决。此题数据范围较大,多重背包会TLE。dp[i]不应该记录容量为i的背包最多能装多少,而应该记录是否能达到容量i。

代码:
#include<iostream>
#include<cstdio>
#include<algorithm>
#include<vector>
using namespace std;
const int maxn=100005;
int num[maxn],w[maxn],flag[maxn],cnt[maxn];
int main()
{
   int i,j,n,m,ans;
   while(~scanf("%d%d",&n,&m))
   {
    if(!n&&!m) break;
    {
     fill(flag,flag+maxn,0);
     flag[0]=1;
     ans=0;
    }
    for(i=1;i<=n;i++) scanf("%d",&w[i]);
    for(i=1;i<=n;i++) scanf("%d",&num[i]);
    for(i=1;i<=n;i++)
    {
     fill(cnt,cnt+maxn,0);
     for(j=w[i];j<=m;j++)
       if(!flag[j]&&flag[j-w[i]]&&cnt[j-w[i]]+1<=num[i])
        {
          ans++;
          flag[j]=1;
          cnt[j]=cnt[j-w[i]]+1;
        }
    }
    printf("%d\n",ans);
   }
   return 0;
}

poj 1742 Coins

原文:https://www.cnblogs.com/VividBinGo/p/11359071.html

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!