首页 > 其他 > 详细

HDU2057 A + B Again(十六进制加法运算)

时间:2019-08-16 21:26:40      阅读:105      评论:0      收藏:0      [点我收藏+]

Problem Description

There must be many A + B problems in our HDOJ , now a new one is coming.
Give you two hexadecimal integers , your task is to calculate the sum of them,and print it in hexadecimal too.
Easy ? AC it !

Input

The input contains several test cases, please process to the end of the file.
Each case consists of two hexadecimal integers A and B in a line seperated by a blank.
The length of A and B is less than 15.

Output

For each test case,print the sum of A and B in hexadecimal in one line.

Sample Input

+A -A +1A 12 1A -9 -1A -12 1A -AA

Sample Output

0 2C 11 -2C -90

 

ps:没看讨论区之前我正在纠结如何将十六进制转成十进制运算再转回到十六进制输出。。。

#include <cstdio>
#include <iostream>
using namespace std;
typedef long long ll;
int main(){
    ll a,b;
    while(scanf("%llX %llX",&a,&b)!=EOF){
        a+=b;
        if(a>=0) printf("%llX\n",a);
        else {
            a=-a;
            printf("-%llX\n",a);
        }
    }
    return 0;
}

HDU2057 A + B Again(十六进制加法运算)

原文:https://www.cnblogs.com/jianqiao123/p/11366151.html

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!