首页 > 其他 > 详细

POJ 3086 Triangular Sums

时间:2014-08-16 21:12:21      阅读:275      评论:0      收藏:0      [点我收藏+]
Triangular Sums
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 6371   Accepted: 4529

Description

The nth Triangular number, T(n) = 1 + … + n, is the sum of the first n integers. It is the number of points in a triangular array with n points on side. For example T(4):

X
X X
X X X
X X X X

Write a program to compute the weighted sum of triangular numbers:

W(n) = SUM[k = 1…nk * T(k + 1)]

Input

The first line of input contains a single integer N, (1 ≤ N ≤ 1000) which is the number of datasets that follow.

Each dataset consists of a single line of input containing a single integer n, (1 ≤ n ≤300), which is the number of points on a side of the triangle.

Output

For each dataset, output on a single line the dataset number (1 through N), a blank, the value of n for the dataset, a blank, and the weighted sum ,W(n), of triangular numbers for n.

Sample Input

4
3
4
5
10

Sample Output

1 3 45
2 4 105
3 5 210
4 10 2145

Source

找规律的一道题,其实题目已经说的很明白了。
先打表再输出,开始怕时限,所以一直改不对,干脆分开算。
代码:
#include <iostream>
#include <algorithm>
#include <stdio.h>
using namespace std;
int f[305],T[305],sum[305];
int main()
{
    int i,j,n,m;
    T[1]=1;f[1]=1;
    for(i=2;i<305;i++)
    T[i]=i+T[i-1];
    for(i=1;i<304;i++)
    f[i]=i*T[i+1];
    sum[1]=f[1];
    for(i=2;i<305;i++)
    sum[i]=sum[i-1]+f[i];
    while(scanf("%d",&n)!=EOF&&n)
    {
        for(i=1;i<=n;i++)
        {
            scanf("%d",&m);
            printf("%d %d %d\n",i,m,sum[m]);
        }
    }
    return 0;
}

POJ 3086 Triangular Sums,布布扣,bubuko.com

POJ 3086 Triangular Sums

原文:http://blog.csdn.net/qq2256420822/article/details/38615959

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!