首页 > 其他 > 详细

PAT Advanced 1009 Product of Polynomials

时间:2019-09-03 01:13:39      阅读:92      评论:0      收藏:0      [点我收藏+]

This time, you are supposed to find A×B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

N?1?? a?N?1???? N?2?? a?N?2???? ... N?K?? a?N?K????

where K is the number of nonzero terms in the polynomial, N?i?? and a?N?i???? (,) are the exponents and coefficients, respectively. It is given that 1, 0.

Output Specification:

For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 3 3.6 2 6.0 1 1.6

求多项式乘积,并输出每个系数非零项的系数和次数。ans[i]存储结果中次数为i的项的系数,src1[i]、src2[i]分别存储输入中次数为i的项的系数。遍历所有非零位相乘,结果存入ans中即可。
#include <bits/stdc++.h>

using namespace std;
float ans[2010],src1[2010],src2[2010];
int main()
{
    int K,tn;
    float an;
    cin>>K;
    for(int i=0;i<K;i++)
    {
        cin>>tn>>an;
        src1[tn]=an;
    }
    cin>>K;
    for(int i=0;i<K;i++)
    {
        cin>>tn>>an;
        src2[tn]=an;
    }
    for(int i=0;i<2010;i++)
    {
        if(src1[i]!=0)
        {
            for(int j=0;j<2010;j++)
            {
                if(src2[j]!=0)
                {
                    ans[i+j]+=src1[i]*src2[j];
                }
            }
        }
    }
    int cnt=0;
    for(int i=0;i<2010;i++)
    {
        if(ans[i]!=0)
            cnt++;
    }
    cout<<cnt;
    for(int i=2009;i>=0;i--)
        if(ans[i]!=0)
        {
            cout<< <<i<< ;
            cout<<fixed<<setprecision(1)<<ans[i];
        }

    cout<<endl;
    return 0;
}

 

PAT Advanced 1009 Product of Polynomials

原文:https://www.cnblogs.com/zest3k/p/11450529.html

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!