首页 > 其他 > 详细

PAT Advanced 1013 Battle Over Cities

时间:2019-09-03 22:46:02      阅读:105      评论:0      收藏:0      [点我收藏+]

It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of the cities connected. Given the map of cities which have all the remaining highways marked, you are supposed to tell the number of highways need to be repaired, quickly.

For example, if we have 3 cities and 2 highways connecting city?1??-city?2?? and city?1??-city?3??. Then if city?1?? is occupied by the enemy, we must have 1 highway repaired, that is the highway city?2??-city?3??.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 3 numbers N (<), M and K, which are the total number of cities, the number of remaining highways, and the number of cities to be checked, respectively. Then M lines follow, each describes a highway by 2 integers, which are the numbers of the cities the highway connects. The cities are numbered from 1 to N. Finally there is a line containing Knumbers, which represent the cities we concern.

Output Specification:

For each of the K cities, output in a line the number of highways need to be repaired if that city is lost.

Sample Input:

3 2 3
1 2
1 3
1 2 3

Sample Output:

1
0
0

求某一城市沦陷后,最少需要维修多少条路来保证剩余的城市连通。去掉与沦陷城市连接的所有道路,用并查集求连通块的个数N,在这些连通块间建造N-1条道路即可将其连成一个连通块。
#include <bits/stdc++.h>

using namespace std;
int lookup(int parent[],int root1)
{
    if(parent[root1]!=root1)
        parent[root1]=lookup(parent,parent[root1]);
    return parent[root1];
}
void join(int parent[],int root1,int root2)
{
    int x=lookup(parent,root1);
    int y=lookup(parent,root2);
    if(x!=y)parent[x]=y;
}

int main()
{
    vector<pair<int,int> > G;
    int N,M,K;
    cin>>N>>M>>K;
    int f,t;
    for(int i=0;i<M;i++)
    {
        cin>>f>>t;
        G.push_back(make_pair(f,t));
    }
    int rem;
    for(int i=0;i<K;i++)
    {
        cin>>rem;
        int parent[N+1];
        for(int j=1;j<=N;j++)
            parent[j]=j;
        for(int j=0;j<G.size();j++)
        {
            if(G[j].first!=rem&&G[j].second!=rem)
            {
                join(parent,G[j].first,G[j].second);
            }
        }

        set<int> s;
        for(int j=1;j<=N;j++)
            if(j!=rem)
                s.insert(lookup(parent,j));
        cout<<s.size()-1<<endl;
    }
    return 0;
}

 

PAT Advanced 1013 Battle Over Cities

原文:https://www.cnblogs.com/zest3k/p/11456004.html

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!