首页 > 其他 > 详细

poj 3264(模板RMQ)

时间:2014-08-18 10:51:04      阅读:333      评论:0      收藏:0      [点我收藏+]
Balanced Lineup
Time Limit: 5000MS   Memory Limit: 65536K
Total Submissions: 34488   Accepted: 16203
Case Time Limit: 2000MS

Description

For the daily milking, Farmer John‘s N cows (1 ≤ N ≤ 50,000) always line up in the same order. One day Farmer John decides to organize a game of Ultimate Frisbee with some of the cows. To keep things simple, he will take a contiguous range of cows from the milking lineup to play the game. However, for all the cows to have fun they should not differ too much in height.

Farmer John has made a list of Q (1 ≤ Q ≤ 200,000) potential groups of cows and their heights (1 ≤ height ≤ 1,000,000). For each group, he wants your help to determine the difference in height between the shortest and the tallest cow in the group.

Input

Line 1: Two space-separated integers, N and Q
Lines 2..N+1: Line i+1 contains a single integer that is the height of cow i 
Lines N+2..N+Q+1: Two integers A and B (1 ≤ A ≤ B ≤ N), representing the range of cows from A to B inclusive.

Output

Lines 1..Q: Each line contains a single integer that is a response to a reply and indicates the difference in height between the tallest and shortest cow in the range.

Sample Input

6 3
1
7
3
4
2
5
1 5
4 6
2 2

Sample Output

6
3
0

Source

USACO 2007 January Silver

就是套模板啦,算法训练指南第198页有详解。

AC代码:

#include<stdio.h>
#include<iostream>
#include<algorithm>
using namespace std;
int n,q;
int a[50010];
int d1[50010][110],d2[50010][110];
void RMQ_init(){
    for(int i=1;i<=n;i++)
        d1[i][0]=d2[i][0]=a[i];

    for(int j=1;(1<<j)<=n;j++)
    for(int i=1;i+(1<<j)-1<=n;i++){
        d1[i][j]=max(d1[i][j-1],d1[i+(1<<(j-1))][j-1]);
        d2[i][j]=min(d2[i][j-1],d2[i+(1<<(j-1))][j-1]);
    }
}
int RMQ1(int x,int y){
    int k=0;
    while((1<<(k+1)<=y-x+1)) k++;
    return max(d1[x][k],d1[y-(1<<k)+1][k]);
}
int RMQ2(int x,int y){
    int k=0;
    while(((1<<(k+1))<=y-x+1)) k++;
    return min(d2[x][k],d2[y-(1<<k)+1][k]);
}
int main(){
    while(scanf("%d%d",&n,&q)!=EOF){
        for(int i=1;i<=n;i++)
            scanf("%d",&a[i]);
        RMQ_init();
        while(q--){
            int x,y;
            scanf("%d%d",&x,&y);
            printf("%d\n",RMQ1(x,y)-RMQ2(x,y));
        }
    }
    return 0;
}


poj 3264(模板RMQ),布布扣,bubuko.com

poj 3264(模板RMQ)

原文:http://blog.csdn.net/my_acm/article/details/38656287

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!