Oulipo
http://acm.hdu.edu.cn/showproblem.php?pid=1686
Time Limit: 3000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 31930 Accepted Submission(s):
12181
Problem Description
The French author Georges Perec (1936–1982) once wrote
a book, La disparition, without the letter ‘e‘. He was a member of the Oulipo
group. A quote from the book:
Tout avait Pair normal, mais tout
s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain,
l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait
au roman : stir son tapis, assaillant à tout instant son imagination,
l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un
non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la
raison : tout avait l’air normal mais…
Perec would probably have scored
high (or rather, low) in the following contest. People are asked to write a
perhaps even meaningful text on some subject with as few occurrences of a given
“word” as possible. Our task is to provide the jury with a program that counts
these occurrences, in order to obtain a ranking of the competitors. These
competitors often write very long texts with nonsense meaning; a sequence of
500,000 consecutive ‘T‘s is not unusual. And they never use spaces.
So we
want to quickly find out how often a word, i.e., a given string, occurs in a
text. More formally: given the alphabet {‘A‘, ‘B‘, ‘C‘, …, ‘Z‘} and two finite
strings over that alphabet, a word W and a text T, count the number of
occurrences of W in T. All the consecutive characters of W must exactly match
consecutive characters of T. Occurrences may overlap.
Input
The first line of the input file contains a single
number: the number of test cases to follow. Each test case has the following
format:
One line with the word W, a string over {‘A‘, ‘B‘, ‘C‘, …, ‘Z‘},
with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
One line
with the text T, a string over {‘A‘, ‘B‘, ‘C‘, …, ‘Z‘}, with |W| ≤ |T| ≤
1,000,000.
Output
For every test case in the input file, the output
should contain a single number, on a single line: the number of occurrences of
the word W in the text T.
Sample Input
3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN
Sample Output
1
3
0
#include<cstdio>
#include<cstring>
const int maxw=10000+3;
const int maxt=1000000+3;
int cas;
char w[maxw],t[maxt];
int next[maxw];
int sum;
int i,j,k;
int main(){
scanf("%d",&cas);
getchar();
while(cas--){
//printf("!!!!!\n");
gets(w);
gets(t);
int lenw=strlen(w);
int lent=strlen(t);
k=-1;
next[0]=-1;
j=0;
while(j<lenw){
if(k==-1||w[j]==w[k]){
k++;
j++;
if(w[j]!=w[k]){
next[j]=k;
}else{
next[j]=next[k];
}
}else{
k=next[k];
}
}
// printf("#### %d\n",next[lenw]);
j=0,i=0;
sum=0;
while(i<lent){
if(j==-1||w[j]==t[i]){
// printf("%d %d\n",j,i);
if(j==lenw-1&&w[j]==t[i]){
sum++;
}
if(j==lenw){
j=next[j];//next[j]表示在第j个字符之前的 从0到j-1的字符串中的最大相同前后缀的值;
}
j++;
i++;
}else{
j=next[j];
}
}
printf("%d\n",sum);
}
return 0;
}
kmp hdu 1686
原文:https://www.cnblogs.com/qqshiacm/p/11508886.html